LMS 2.5.1 - Unable to take IOS backup

Unanswered Question
Jul 24th, 2007

I am able to take IOS backup in RME from all my devices 2950,2970,4948 etc except from 3 Cisco 3750 Stack switches. The Credential verification reports verfies all OK and all other things are working fine. When I try to take IOS backup at RME>Sw mgmt> Sw repositiry >Add, it is not able to identify imgae from flash. This is a common problem with all 3 Cisco 3750 switches. I have attached some snapshots.

Can anyone Please suggest ??

Regards

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
jreekers Thu, 07/26/2007 - 10:08

Hi.

Check the flash on the device and ensure that it is a BIN image (not a TAR) that is in the flash directory. If the image is in a subdirectory, you may be running into this bug:

CSCsb59359 - Import image from Subdirectory should be supported for 3750 stack device

Symptom:

Using 3750 stack device try to import .bin image from device.

Error seen:

SWIM0014: No images to import. If not a CLI based device, Check DDR if it has the latest information. If not, update inventory and try the Import operation again.

Conditions:

There are no bin images present directly under the flash directory but are present under their subdirectories.

Workaround:

Copy the .bin images from the flash subdirectory directly into flash directory.

And then retry the Import from device flow.

HTH,

-J

nitinmathur Thu, 07/26/2007 - 19:46

Hi,

You are absolutely right. The image is in sub-dir so I may be hitting a bug. The Symptoms and Error are same as described and the snapshots of same are already attached with this thread. I will try the workaround and update.

Thanks & Regards,

Martin Ermel Fri, 07/27/2007 - 00:46

but you should be careful using this 'Workaround' if you have 3750 configured as a stack; the 'archive' command will not work anymore on the cli because it needs the SW in the subdir. Also the automatic SW distribution from the master to the members will be broken... (and perhaps there are more issues..)

I hope that Cisco will update the RME device package soon!

It is probably a better idea to import the image from CCO or a filesystem.

Actions

This Discussion