RME 4.0.x: SyslogCollector cannot resurrect

Unanswered Question
Jul 25th, 2007

...

SyslogCollector - [Thread: SyslogObjectForwarder] INFO , 23 Jul 2007 12:04:55,44

1, FcssSubscriber - After write

SyslogCollector - [Thread: SyslogObjectForwarder] INFO , 23 Jul 2007 12:05:01,45

1, FcssSubscriber - After write

SyslogCollector - [Thread: SyslogObjectForwarder] ERROR, 23 Jul 2007 12:05:37,62

0, Could not send syslogs, removing the subscriber...Connection refused

SyslogCollector - [Thread: main] INFO , 23 Jul 2007 12:16:58,911, Logging System

Initialized.

SyslogCollector - [Thread: main] INFO , 23 Jul 2007 12:16:58,914, System Initial

ized.

SyslogCollector - [Thread: main] WARN , 23 Jul 2007 12:17:02,513, Unable to resu

rrect connection to a subscriber.

SyslogCollector - [Thread: main] INFO , 23 Jul 2007 12:17:02,567, Service starte

d...

SyslogCollector - [Thread: SyslogObjectForwarder] ERROR, 23 Jul 2007 12:20:47,33

3, Could not send syslogs, removing the subscriber...Connection refused

pdshow:

Process= SyslogCollector

State = Program started - No mgt msgs received

Pid = 232

RC = 0

Signo = 0

Start = 07/23/07 12:16:57

Stop = Not applicable

Core = Not applicable

Info = Application started by administrator request.

Tried restarting SyslogCollector, to no avail...

lsof -i :4444

COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME

cwjava 3547 casuser 17u IPv4 0x3003d54e4b8 0t0 TCP *:4444 (LISTEN)

lsof -i :3333

COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME

cwjava 3547 casuser 20u IPv4 0x300214424f0 0t3430 TCP nms:45507->nms:3333 (ESTABLISHED)

cwjava 3564 casuser 27u IPv4 0x3001a4e84d8 0t0 TCP *:3333 (LISTEN)

cwjava 3564 casuser 29u IPv4 0x3001ccf8630 0t12682 TCP nms:3333->nms:45507 (ESTABLISHED)

Debug SyslogCollector.log attached:

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
yjdabear Wed, 07/25/2007 - 09:44

Kill -HUP on the syslogd pid made no difference. Debugging with logger seems to show syslogging on the LMS server is fine, but can't test the syslog LMS reads because it's on a read-only NFS mount.

Finally, manually subscribing to "hostname" seemed to do the trick, even though "hostname" has been showing up in Collector Status (with N/A across the board) all along.

Actions

This Discussion