pat on ios

Unanswered Question
Jul 25th, 2007

IOS newbie here trying to pat inside hosts to the address on e1/0.

I'm sure there's not much to it, any help would be great. Thanks everyone.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
sundar.palaniappan Wed, 07/25/2007 - 10:56

R1(config)#ip nat inside source list 100 interface e1/0 overload

R1(config)#access-list 100 permit ip any any

R1(config)#int e1/0

R1(config-if)#ip nat outside

R1(config-if)#int e0/0

R1(config-if)#ip nat inside

Am sure you know if you want to be specific about the inside network to be NATted then change the access list accordingly.



acomiskey Wed, 07/25/2007 - 11:04

Thanks, so this is really how it is. Would it still be the same. Should e1/0 be "ip nat outside"?

Hosts inside FastEthernet0/0 are going out through e1/0.

sundar.palaniappan Wed, 07/25/2007 - 11:08

Oops sorry e1/0 should be outside. I corrected my previous post to reflect that.

You are correct. This is the IOS equivalent of the PIX global (outside) 1 interface command.



Jon Marshall Wed, 07/25/2007 - 10:59

Hi Adam

If inside hosts are and assuming they connect on e0/0 interface

access-list 1 permit

ip nat inside source list 1 interface e1/0 overload

interface e0/0

ip nat inside

interface e1/0

ip nat outside



acomiskey Wed, 07/25/2007 - 11:08

Thanks guys...

I had

access-list 1 permit

and it didn't work?

sundar.palaniappan Wed, 07/25/2007 - 11:11


I believe you need to use an extended access list for NAT in IOS. Although I may have seen it work with a standard access list.

Glad you got it to work :-)



Jon Marshall Wed, 07/25/2007 - 11:15

Hi Sundar

You can use a normal access-list with NAT on IOS. Extended access-lists are useful if you want to do policy NAT.


sundar.palaniappan Wed, 07/25/2007 - 11:21


I thought so but I wasn't positive about it.

Apparently the reason why the standard ACL Adam using wasn't working is because it was showing as 'host' rather than 'any'.




This Discussion