Wanky CLI prompts on Catalyst 2900 XL

Unanswered Question
Jul 25th, 2007

I inherited three Catalyst 2900 XL switches (2924) in an office move. One of them appears to work fine, but the other two give me wanky CLI prompts when I try to configure them via the console.

One switch freezes when trying to copy config.text from flash: to system: ... the other switch doesn't let me get to the configuration setup -- it just slams right past it whether I answer Y or N to the prompt.

So are these two switches boat anchors at this point? Or does the software in flash memory need to be refreshed? And if so, can I do that without having to purchase a Cisco support contract?

It might just be cheaper and easier for me to go out and buy some unmanaged 24-port switches for a few hundred bucks, but I'd like some knowledgeable opinion before I do that.

Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jagdeep Gambhir Thu, 07/26/2007 - 15:23

Try formatting the flash and upload IOS again,

Format flash

2924-XL#format flash:

Format operation may take a while. Continue? [confirm]

Once the Flash was formatted please upload the image from a TFTP to the switch.

Instructions on how to upgrade are available here:

http://www.cisco.com/univercd/cc/td/doc/product/lan/c2900xl/29_35wc9/ol256205.htm#706188

Please do not reboot the switch until you can have uploaded the image and until you have changed the boot sequence.

Regards,

thomaslundin Thu, 07/26/2007 - 17:58

Thanks for the tip; I'll give it a try after our office move is complete over the weekend!

Actions

This Discussion