load-balancing in the same IP subnet

Answered Question
Jul 25th, 2007

Can I use load-balancing in the same IP subnet? I have the servers and client in the same IP subnet. I'd like to load-balance client traffic to server traffic. I also need to load balance traffic between servers. Is possible to configure it only in one VLAN?

For example:

CSS:

interface 4/2

circuit VLAN1

ip address 10.0.0.10 255.255.255.0

service s1

ip address 10.0.0.101

active

service s2

ip address 10.0.0.102

active

service s3

ip address 10.0.0.103

active

service s4

ip address 10.0.0.104

active

owner test

content client

vip address 10.0.0.3

add service s1

add service s2

active

content servers

vip address 10.0.0.4

add service s3

add service s4

active

Cat6500:

interface FastEthernet4/1 - clients

no ip address

switchport

switchport mode access

spanning-tree portfast

interface FastEthernet4/2 - servers

no ip address

switchport

switchport mode access

spanning-tree portfast

interface FastEthernet4/3 - CSS

no ip address

switchport

switchport mode access

spanning-tree portfast

interface Vlan1

ip address 10.0.0.1 255.255.255.0

ip policy route-map pokus

access-list 101 permit tcp any eq 80 any

route-map pokus permit 10

match ip address 101

set ip next-hop 10.0.0.10

Thank you

Roman

I have this problem too.
0 votes
Correct Answer by Martin Kyrc about 9 years 4 months ago

Configuration on the slide is OK. On the c6500 are interfaces in *switchport* mode (the same situation on the CSS). In other words, information about VLAN is not 'transferred' to the CSS.

for CSS are servers and clients accessible through vlan10, but in real are server located in vlan20 and clients in vlan10. this method is called 'transparent bridge mode' (I had use it only ones, or twice).

I think, more preferred for you (because you have only one link between css and c6500) is bridge mode (no transparent bridge mode). That's only my recommendation.

regards,

martin

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Martin Kyrc Wed, 07/25/2007 - 12:49

Hi Roman,

yes, it's possible.

1. for load-balancing (LB) in the same IP subnet use 'bridge mode' (two vlans, one ip subnet)

2. do you need LB server's traffic? that means, src (server) connect VIP and dst is the same server (or server in the same ip pool and vlan)? sure? in this case is necessary to use 'client nat', because src connect vip (css), css connect dst, but response withour client nat will be answered direct to the src and not through css.

I'm not sure, if this second answer is useful for you.

martin

ROMAN TOMASEK Wed, 07/25/2007 - 23:22

Thank you.

So I have to use two vlans:-( Can you send me the configuration example of the bridge mode?

Thank you

Roman

ROMAN TOMASEK Thu, 07/26/2007 - 02:26

Can I use bridge mode in the one-arm topology? I have CSS connected only with one link with the Cat6500. I have the problem to understand why there are two links with the same VLAN on the picture, which is in the attachments.

Thank you.

Martin Kyrc Thu, 07/26/2007 - 04:20

yes, it's possible - use trunk with two VLANs (slide 9). or you can use 'transparent' mode (slide 11 - your attachment).

answer to your question (I have the problem to understand why there are two links with the same VLAN on the picture):

on the switch are two port interfaces in *switchport* mode (not trunk). now is it clearly?

result:

both methods (bridge mode with two vlans, or transparent bridge mode) use two vlans. it's on you, which type is for you preferred.

my recommendation is - use first method - one link to CSS with trunk configured in bridge mode (one ip subnet, two vlans, default gw for servers isn't css, but parent router)

martin

ROMAN TOMASEK Thu, 07/26/2007 - 04:40

Hi,

thank you for your exhausting answer.:-) I have the last question (I promise): in the slide 11 - on the CSS is:

interface 1/1

bridge vlan 10

interface 1/2

bridge vlan 10

and on the switch:

int FE 4/1

switchport access vlan 10

int FE 4/2

switchport access vlan 20

here are different vlans - on css is only vlan 10 and on the switch are vlans 10, 20;-( Is the configuration correct??

I think that good config is following:

interface 1/2

bridge vlan 20

Thank you

Roman

Correct Answer
Martin Kyrc Thu, 07/26/2007 - 04:55

Configuration on the slide is OK. On the c6500 are interfaces in *switchport* mode (the same situation on the CSS). In other words, information about VLAN is not 'transferred' to the CSS.

for CSS are servers and clients accessible through vlan10, but in real are server located in vlan20 and clients in vlan10. this method is called 'transparent bridge mode' (I had use it only ones, or twice).

I think, more preferred for you (because you have only one link between css and c6500) is bridge mode (no transparent bridge mode). That's only my recommendation.

regards,

martin

Actions

This Discussion