Does Catalyst 3550 support inter vlan routing

Unanswered Question
Jul 25th, 2007


Does Catalyst 3550 switch support inter vlan routing ?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
limjewyen Wed, 07/25/2007 - 18:21

I am having the same problem i need to buy any modules for add-ons in order to configure inter vlan routing ? mine running on 12.1version....

lamav Wed, 07/25/2007 - 18:24

The 3550 is a L3 IOS-based switch. You must turn on ip routing.

What exactly are you having a problem doing?

limjewyen Wed, 07/25/2007 - 18:53

Basically I am trying to configure an isolated LAN using CAT3550 but at the same time to configure intervlan routing so that it can talk to my production lan.

am trying to setup an secured network...

Jon Marshall Wed, 07/25/2007 - 18:25


The 3550 does support inter-vlan routing but the routing protocols it supports depends on the software version ie the SMI version only supports RIP + static routing.

For other routing protocol support you need the EMI version.



limjewyen Wed, 07/25/2007 - 18:40

Does mine supports? I have attached my version here.

------------------ show version ------------------

Cisco Internetwork Operating System Software

IOS (tm) C3550 Software (C3550-I9Q3L2-M), Version 12.1(20)EA1, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2004 by cisco Systems, Inc.

Compiled Wed 04-Feb-04 23:08 by yenanh

Image text-base: 0x00003000, data-base: 0x006B3334

ROM: Bootstrap program is C3550 boot loader

uptime is 13 weeks, 5 days, 18 hours, 54 minutes

System returned to ROM by error - Instruction Access Exception (0x0400)!, PC 0x334C322C

System restarted at 17:26:28 SPORE Wed Aug 17 2005

System image file is "flash:c3550-i9q3l2-mz.121-20.EA1/c3550-i9q3l2-mz.121-20.EA1.bin"

cisco WS-C3550-24-PWR (PowerPC) processor (revision E0) with 65526K/8192K bytes of memory.

Processor board ID CAT0803Z3E6

Last reset from warm-reset

Running Layer2/3 Switching Image

Ethernet-controller 1 has 12 Fast Ethernet/IEEE 802.3 interfaces

Ethernet-controller 2 has 12 Fast Ethernet/IEEE 802.3 interfaces

Ethernet-controller 3 has 1 Gigabit Ethernet/IEEE 802.3 interface

Ethernet-controller 4 has 1 Gigabit Ethernet/IEEE 802.3 interface

24 FastEthernet/IEEE 802.3 interface(s)

2 Gigabit Ethernet/IEEE 802.3 interface(s)

The password-recovery mechanism is enabled.

384K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address:

Motherboard assembly number: 73-8100-07

Power supply part number: 341-0029-03

Motherboard serial number: CAT080401ZD

Power supply serial number: LIT075001TN

Model revision number: E0

Motherboard revision number: A0

Model number: WS-C3550-24PWR-SMI

System serial number:

Configuration register is 0x10F

Jon Marshall Wed, 07/25/2007 - 18:46


Yes they all do. Can you post config of your switch if you are having problems.


limjewyen Wed, 07/25/2007 - 19:00

Basically I am trying to configure an isolated LAN using CAT3550 but at the same time to configure intervlan routing so that it can talk to my production lan.

am trying to setup an secured network...

cisconoobie Thu, 07/26/2007 - 08:52


Do this: #ip routing

Create a vlan and add a port into that vlan

Then do #interface vlan (number)

put the Ip address of the vlan interface

With the interface vlan XXX command you enable intervlan routing between vlans.

If you want your production lan to connect to this 3550, then you need to setup some type of connection to it. You need to allow your production lan to be able to route to the 3550 either through static routes or a routing protocol.

lamav Thu, 07/26/2007 - 09:09


Interestingly enough, I found myself trying to do the same thing using a 3550 switch a few years back.

I think I understand what you're trying to do.

I'll tell you the way I did it...

I created a segregated vlan by using very granular ip access lists to filter traffic.

YOu have to create the SVI interface for the vlan, apply a network IP address and mask, turn up the SVI with the "no shutdown" command, and then advertise that network under the route protocol instance.

Do the same with other vlans. Create them and add their networks to the routing process on the switch.

NOTE: For any SVI interface to go to an "up, up" state, at least ONE end-device must be placed in that vlan, and that device must be successfully connected to the ethernet interface. In other words, the switch's physical interface that is connected to the end-device must be in an "up, up" state.

Once the SVIs for EACH vlan you have created are "up,up" and the routing process has been enabled, devices on each vlan will become reachable, including on the segregated vlan.

Now, to make a vlan segregated, you can use granular IP access lists to filter the traffic.



Liam Dwyer Wed, 01/16/2013 - 12:06

I have done the above and i am still getting crosstalk with DHCP.

Any help??

Here is part of my config on the core switch...

My secondary DHCP is plugged in to port gig 0/12 and that is currently set to access vlan 15 which is also my new gear.

interface GigabitEthernet0/12

switchport access vlan 15

switchport trunk allowed vlan 15

no ip address


interface Vlan1

ip address


interface Vlan2

description hotel_admin

no ip address


interface Vlan12

description TMOBILE

no ip address


interface Vlan15

ip address

ip helper-address


ip default-gateway

ip classless

ip route name MX400

ip http server



snmp-server engineID local 800000090300000CCEAC8001

snmp-server community tbmanager RW

snmp-server community tbconferences RO

snmp-server host tbconferences


line con 0

password 7 0459190D210F1D


line vty 0 4

password 7 0111140F752557


line vty 5 15

password 7 13070519252255



John Blakley Wed, 01/16/2013 - 12:14

Please start a new thread...this one is 6 years old...


*** Please rate all useful posts ***


This Discussion