QUESTION ABOUT BRIDGING/BRIDGE GROUPS

Unanswered Question
Jul 25th, 2007
User Badges:
  • Blue, 1500 points or more

Here is the DLSW config from an L3 CatOS swtich Im working on.


bridge 1 protocol ieee

bridge 2 protocol ieee

bridge 3 protocol ieee

bridge 4 protocol ieee

bridge 5 protocol ieee

bridge 6 protocol ieee

bridge 7 protocol ieee




interface Vlan73

description Server VLAN73

ip address 10.0.16.2 255.255.255.0 secondary

ip address 10.27.73.2 255.255.255.0

no ip redirects

no ip unreachables

ipx input-network-filter 902

ipx input-sap-filter 1002

ipx encapsulation SAP

ipx network A1B4900

ipx output-gns-filter 1050

standby 16 ip 10.0.16.1

standby 16 timers 5 15

standby 16 priority 175

standby 16 preempt

standby 73 ip 10.27.73.1

standby 73 timers 5 15

standby 73 priority 175

standby 73 preempt

bridge-group 1

bridge-group 1 input-address-list 702


dlsw local-peer peer-id 10.27.13.1

dlsw remote-peer 0 tcp 10.27.2.1

dlsw remote-peer 0 tcp 10.27.1.1

dlsw bridge-group 1

dlsw bridge-group 2

dlsw bridge-group 3

dlsw bridge-group 4

dlsw bridge-group 5

dlsw bridge-group 6

dlsw bridge-group 7


Its very straightforward. Nothing weird about it, except that this is the only interface in this bridge group. There are also 2 other SVIs that are put into 2 different bridge groups, too. So, what we have are 3 SVIs with each of them being placed in 3 different bridge groups.


Thats what is confusing me. Whats the point of only putting one vlan in a bridge group? i thought the point of the group is to be able to bridge (pass) traffic between machines on different network segments that are running non-routable protocols, like SNA, etc.


In other words, I would expect to see 2, 3 or more SVIs being placed in the same bridge group so that devices on each of those vlan can pass traffic between each other.


what am I missing?


SEE THE ATTACHED DIAGRAM AND NOTICE HOW SEVERAL VLANS ARE PUT IN A BRIDGE GROUP.





Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Richard Burts Thu, 07/26/2007 - 07:42
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Victor


Your question is a very good representation of the traditional use of bridge-group where you use it to enable bridging between several segments on the local device. But in looking at the configuration it becomes obvious that the bridge-group is being used for something else. The best clue is this:

dlsw bridge-group 1

which shows that the bridge-group is being used to get non-routed traffic (like SNA) and put it into DLSW so that it can be sent to a remote peer (DLSW encapsulates the bridged traffic in IP datagrams for transport over the IP network) and on the remote peer that traffic will be bridged to its destination.


HTH


Rick

lamav Thu, 07/26/2007 - 08:55
User Badges:
  • Blue, 1500 points or more

Rick:


I think I get it. Fallback bridging CAN be used for th epurpose I described. That is, to bridge non-IP traffic across different network segments, right?


HOWEVER, in this case, the bridge-group commands under the different vlan interfaces are meant to enable DSLw on that interface. Am I right?


Funny, I knew what the DLSw is for an dhow it works, but never actually configured, so I wasnt aware of how ot go about doing it. hence, my question...


Thanks, Rick!


Richard Burts Thu, 07/26/2007 - 17:12
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Victor


Yes you are right, the bridge-group can be used for several different things. In this case it is to enable DLSW on these interfaces.


I am glad that it is now more clear for you.


HTH


Rick

lamav Thu, 07/26/2007 - 20:25
User Badges:
  • Blue, 1500 points or more

Great! I rated your post, by the way.

Richard Burts Sat, 07/28/2007 - 18:25
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Victor


Thanks for the rating. The forum is a very good place to get questions answered and to improve our understanding of networking concepts. I encourage you to continue your participation in the forum.


HTH


Rick

Actions

This Discussion