Access with RSH

Unanswered Question
Jul 26th, 2007

Hi,

I try to collect IP data (for accounting)from a 3745 Cisco router with IPAcco software on Linux platform.

The configuration on router, regarding to RSH, are below:

ip rcmd rsh-enable

ip rcmd remote-host root IP-address root enable

username root password 7 password

Where the IP Address is the IP of the remote machine and password is a local password of root.

I execute this command on Linux machine: rsh IPRouterAddress show ip accounting, but the log on router show this:

Jul 26 08:55:24.044: RCMD: [514 <- IP_Address_Linux_Machine:1023] recv 1022\0

Jul 26 08:55:24.296: RCMD: [514 <- IP_Address_Linux_Machine:1023] recv root\0root\0show ip acconting\0

Jul 26 08:55:24.296: RCMD: [514 -> IP_Address_Linux_Machine:1023] send <OK>

Jul 26 08:55:24.296: RCMD: [514 -> IP_Address_Linux_Machine:1023] send <BAD,Access denied.>\n

When I use a Windows platform there are no problem; infact I've access to router.

Anyone have a solution to this problem?

Thanks in advance.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
carenas123 Wed, 08/01/2007 - 05:38

The no ip rcmd rsh-enable command does not prohibit a local user of the router from executing a command on other routers and UNIX hosts on the network using rsh. The no form of this command only disables remote access to rsh on the router.

For more information on rsh please click following link:

http://www.cisco.com/en/US/products/sw/iosswrel/ps1831/products_command_reference_chapter09186a00800d9833.html#1018286

Actions

This Discussion