Problems with command ip next-hop verify-availability

Unanswered Question
Jul 26th, 2007

My name is Nelson and I?m implementing a network solution in a client. The client have several sites with two routers (one for IP/MPLS and another one for ADSL-Internet access only). The client wants that when the ADSL connection goes down, the Internet access will go by IP/MPLS router. I implement HSRP with PBR and everything works fine when I drop the ADSL connection. But when I put the connection up again, the internet traffic don?t come back to ADSL router.

I?m using the command ?ip next-hop verify-availability where corresponds to public IP of ADSL connection. If I use the ethernet IP of the router it works but if I use the public IP of ADLS it doesn?t.

How can I do it ?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (3 ratings)
Amit Singh Thu, 07/26/2007 - 03:09


What is the config for ADSL router. Do you want the ADSL to be the primary connection always and IP/MPLS to be a standby one and when the ADSL goes out the IP/MPLS should kick-in.

If yes, then you can simply achieve it by using the HSRP interface tracking feature. I see that you have already configured the tracking on IP MPLS router. Please ensure that you also use the decrement value so that your standby router comes and and when the primary link comes back it should automatically switch-over to primary router.

I see that you have also configured PBR to achieve this, which is really not necessary.

There are two ways to do this:

1. Using HSRP, Object tracking:

Config from my routers :

So the config will be as follows

Router A


track 100 interface Serial0/0/0:1 line-protocol

interface FastEthernet0/0

ip address x.x.x.1

standby 1 ip x.x.x.3

standby 1 priority 130

standby 1 preempt

standby 1 track 100 decrement 30

Router B


interface FastEthernet0/0

ip address x.x.x.2

standby 1 ip x.x.x.3

standby 1 priority 110

standby 1 preempt

2. Using the HSRP interface tracking:

HTH,Please rate if it does.

-amit singh

nmendes349 Thu, 07/26/2007 - 03:27

Thanks for the response.

The problem is not the HSRP. That one works just fine.

The active router is the IP/MPLS router. The problem is: when adsl session (not router) goes down, the track goes down and the PBR don?t match. Then the internet traffic start going by IP/MPLS. So far so good.

When the adsl connection goes up, the track also comes up and the PBR match, but the internet traffic don?t go to ADSL router. It still go by IP/MPLS router.

syed_aleef Mon, 07/30/2007 - 20:37


I hope you could help me.

I have 2 cisco 2900 series routers in HSRP.(router A and router B)

Router A is Active, Router B is standby connected to internet thru lease line

Problem is packets coming from standby router to internal network, going back with Active router and the packets are drop.

so how can i reslove it.

thank in advance


manmeetmarwah Thu, 07/26/2007 - 03:20

Hi Nelson,

Kindly send complete configuration of both the routers to understand the setup more efficiently. Also Iam considering that your IP/MPLS link is also being used for Internet traffic other than ADSL link which is primarily used for Internet.


nmendes349 Thu, 07/26/2007 - 03:38

Correct, the IP/MPLS router have a connection to central site that have a dedicated circuit to internet. Then, when ADSL connection on remote site goes down, the internet traffic should go by IP/MPLS router.

In attach goes both configurations.

manmeetmarwah Thu, 07/26/2007 - 04:06


From the configuration you sent, I can conclude the following & would require more information as asked below:

1) You have configured HSRP and thus the default gateway of users is

2) In normal case, the traffic would be first forwarded to setubal 2801 router due to its high priority.

3) You have applied a route map on 2801 router saying that all traffic matching www i.e. internet should be forwarded to next-hop which is " My query over here is that this IP address is of which router??"

4) Also you have put a static route for towards your 877-ADSL router, Which means that you are forwarding the internet traffic always towards 877 router in case the next hop is available.

I hope there is some problem in the configuration.Please check the same and confirm.

Also refer to the following link for more clarity on the PBR configuration:


nmendes349 Thu, 07/26/2007 - 05:34


The default gateway of PCs are

The traffic goes first to 2801 and then is splited (if is internet traffic it goes to cisco 877-ADSL)

The public IP of cisco 877 is (I?m tracking this IP because I want to "monitorize" if the connection goes down). If the ADSL connection went down, the PBR don?t match and the traffic go by network IP/MPLS (the 2801 receive a default route from network).

The static route in 2801 to the public IP of cisco 877 is because I want to track that IP address and the 2801 does not know the route to that IP so I have to force it. But I?m not forwarding the internet traffic with that route. I?m force it with the PBR.

manmeetmarwah Thu, 07/26/2007 - 22:05

Hi Nelson,

Try putting the following commands in the 2801 router:

rtr 1

type echo protocol ipicmpecho

rtr schedule 1 start-time now life forever

track 123 rtr 1 reachability

route-map routeweb

match ip address 101

set ip next-hop verify-availability 83.x.x.85 10 track 123

Also enable CDP on the dialer interface of ADSL router & check the flow.


nmendes349 Fri, 07/27/2007 - 02:24


I will activate CDP at interface Dialer1 (router ADSL) and test.

The other configuration in router 2801 I already have it but when I introduce


rtr 1

type echo protocol ipicmpecho

rtr schedule 1 start-time now life forever


in configuration mode, then when I do show running-config it apears:


ip sla monitor 1

type echo protocol ipIcmpEcho

ip sla monitor schedule 1 life forever start-time now


I don?t think this is important but I?m curious why this happens.

manmeetmarwah Fri, 07/27/2007 - 02:57

The SAA (rtr) feature was replaced by the IP SLAs feature in IOS version 12.4 onwards.


Pls rate if helpful


This Discussion