No MOH music on CME phone while linksys phone press hold

Unanswered Question
Jul 26th, 2007

CME4.1 works with Linksys SIP phone, everthing works fine. Only MOH does not work as linksys phone press hold key, the other side silience. But SCCP phone put the linksys phone on hold, linksys can hear MOH server music.

What command does Linksys phone for MOH?

Please help me with thanks!

I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Paolo Bevilacqua Thu, 07/26/2007 - 05:24

Sorry, I think MOH is not supported for SIP phones.

Hope this helps, please rate post if it does!

xaba-xaba Mon, 05/31/2010 - 08:05

Hi all!

I has same problem. MOH support on SIP-telephony. I load Cisco 7906 on sip-protocol - MOH played OK!

But on Linksys SIP-phone MOH not play   Why? There is option Moh server on web-interface of linksys phone.  i don't know how to use. I try ip-address of CME, multicast ip-address, and tftp-server witch MOH - NOT OK.

Topickstarter - did you solve the problem?

Please, help me!

P.S.: sorry for my bad english

xaba-xaba Mon, 05/31/2010 - 23:32

It's stand configuration

Cisco 2811 with IOS 15.1T + hub + SPA942 + Cisco 7906 + Notebook with x-lite

Router#sh run
Building configuration...


Current configuration : 7345 bytes
!
! Last configuration change at 18:26:45 MSD Mon May 31 2010 by cisco
! NVRAM config last updated at 19:08:59 MSD Mon May 31 2010 by cisco
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot system flash c2800nm-adventerprisek9-mz.151-1.T.bin
boot-end-marker
!
enable secret 5 $1$6XYk$qGhMzHmSu.J4PbEQgLGdh/
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
aaa authorization network default local
!
!
!
!
!
aaa session-id common
!
clock timezone MSK 3
clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 3:00
!
dot11 syslog
ip source-route
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1 192.168.1.20
!
ip dhcp pool IpPhone
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.250
   option 150 ip 192.168.1.250
   option 66 ascii 192.168.1.250
!
!
ip name-server 91.210.44.1
ip multicast-routing
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
voice call send-alert
voice call disc-pi-off
voice rtp send-recv
!
voice service voip
address-hiding
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service h450.2
no supplementary-service h450.3
supplementary-service h450.12
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
redirect ip2ip
sip
  registrar server
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
codec preference 4 g726r16
codec preference 5 g726r24
codec preference 6 g726r32
!
!
voice register global
mode cme
source-address 192.168.1.250 port 5060
max-dn 144
max-pool 42
load 7906 SIP11.8-4-2S
authenticate register
timezone 32
time-format 24
date-format D/M/Y
hold-alert
dialplan-pattern 1 4.. extension-length 3
call-forward system redirecting-expanded
external-ring bellcore-dr3
tftp-path flash:
file text
create profile sync 0215281773239841
!

!it's Linksys SPA942 phone
voice register dn  1
number 400
allow watch
pickup-call any-group
pickup-group 1
no-reg
!

!It's cisco 7906 phone
voice register dn  2
number 401
allow watch
pickup-call any-group
pickup-group 1
no-reg
!

!it's x-lite softphone
voice register dn  3
number 402
allow watch
pickup-call any-group
pickup-group 1
no-reg
!
voice register pool  1
id mac 000E.083A.2FA3
type 7906
number 1 dn 1
presence call-list
dtmf-relay rtp-nte sip-notify
voice-class codec 1
username 400 password 400
no vad
blf-speed-dial 1 400 label "400"
!
voice register pool  2
id mac 0019.306F.A30A
type 7906
number 1 dn 2
presence call-list
dtmf-relay rtp-nte sip-notify
voice-class codec 1
username 401 password 401
no vad
blf-speed-dial 1 401 label "401"
!
voice register pool  3
id mac 0014.0B0C.2A7E
number 1 dn 3
presence call-list
dtmf-relay rtp-nte sip-notify
voice-class codec 1
username 402 password 402
no vad
blf-speed-dial 1 402 label "402"
!

!
voice hunt-group 1 sequential
list 400,401
timeout 10
pilot 600
!
!
voice hunt-group 2 longest-idle
list 401,400
timeout 10
pilot 601
!
!
!
!
voice translation-rule 1
rule 1 /^98/ /7/
rule 2 /^9/ /7861/
rule 3 /^9810/ //
!
voice translation-rule 2
rule 1 /^98/ /8/
rule 2 /^9/ /8861/
rule 3 /^9810/ //
!
!
voice translation-profile sipnet
translate called 1
!
voice translation-profile telphin
translate called 2
!
!
voip-incoming translation-rule called 10
voice-card 0
!
!it's AutoAttendand
application
service app-b-acd-aa
  param voice-mail 5003
  paramspace english index 0
  param max-time-call-retry 60
  param service-name app-b-acd
  param number-of-hunt-grps 1
  param menu-timeout 0
  paramspace english language en
  param handoff-string app-b-acd-aa
  param dial-by-extension-option 4
  param operator 400
  param max-time-vm-retry 1
  paramspace english location flash:
  param max-extension-length 3
  param aa-pilot 200
  param second-greeting-time 15
  param welcome-prompt _bacd_welcome.au
  param call-retry-timer 15
!
service app-b-acd
  param queue-len 5
  param aa-hunt2 600
  param number-of-hunt-grps 1
  param queue-manager-debugs 1
!
!
!
!
!        
!
archive
log config
  hidekeys
username cisco password 0 cisco
!
redundancy
!
!
!Test rule for incoming call
translation-rule 10
Rule 1 ^00562653300 600
!
!
!
!
!
!
!
!
!        
interface Loopback1
ip address 192.168.3.250 255.255.255.0
!

!Wan - my corporate LAN. There is CME witch SCCP ephones. It emulated external PSTN
interface FastEthernet0/0

description To_WAN
ip address 192.168.2.251 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1

description To_LAN_IpPhones
ip address 192.168.1.250 255.255.255.0
ip flow ingress
ip flow egress
duplex auto
speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 0.0.0.0 0.0.0.0 192.168.2.250
!
!        
!
!
!
!
tftp-server flash:music-on-hold.au
!
!
control-plane
!
!
!
mgcp fax t38 ecm
!
!

!This dial-peer's to external sip-operator. Not work's now.
dial-peer voice 1 voip
translation-profile outgoing sipnet
destination-pattern 98..........
session protocol sipv2
session target dns:sipnet.ru
session transport udp
voice-class codec 1
voice-class sip localhost dns:sipnet.ru preferred
dtmf-relay rtp-nte sip-notify
no vad
!
dial-peer voice 2 voip
translation-profile outgoing sipnet
destination-pattern 9[2-7,9]......
session protocol sipv2
session target dns:sipnet.ru
session transport udp
voice-class codec 1
voice-class sip localhost dns:sipnet.ru preferred
dtmf-relay rtp-nte
no vad
!
dial-peer voice 3 voip
translation-profile outgoing sipnet
destination-pattern 9810T
session protocol sipv2
session target dns:sipnet.ru
session transport udp
voice-class codec 1
voice-class sip localhost dns:sipnet.ru preferred
dtmf-relay rtp-nte
no vad
!

!Incoming dial-peer
dial-peer voice 1000 voip
session protocol sipv2
incoming called-number .%
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
!

!Dial-peer to external phones on my corporate CME
dial-peer voice 400 voip
destination-pattern 1..
session protocol sipv2
session target ipv4:192.168.2.250
voice-class codec 1
no vad
!
dial-peer voice 5000 voip
description === B-ACD entry ===
service app-b-acd-aa
destination-pattern 200
session target ipv4:192.168.1.250
incoming called-number 200
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
!
presence
presence call-list
max-subscription 144
!

!Sip-account
sip-ua
credentials username 9030391 password 7 ******** realm etc.tario.ru
authentication username 9030391 password 7 ********* realm etc.tario.ru
presence enable
!
!
!        
telephony-service
no auto-reg-ephone
max-ephones 10
max-dn 10
ip source-address 192.168.1.250 port 2000
calling-number initiator
service directed-pickup gpickup
max-conferences 8 gain -6
call-park system application
moh flash:/music-on-hold.au
multicast moh 224.168.168.168 port 6061
transfer-system full-consult
transfer-pattern .T
fac custom pickup local *36 !it's for pick-up service on linksys
fac custom pickup group *37
create cnf-files version-stamp 7960 May 27 2010 16:52:10
!
!
line con 0
line aux 0
line vty 0 4
transport input all
!        
scheduler allocate 20000 1000
ntp master
ntp server 194.67.0.206
ntp server 194.67.0.92
end

Router#

xaba-xaba Mon, 05/31/2010 - 23:48

i'm attach debug log witch my comments. 2 files. First - witch log of press hold on cisco sip-phone, second - witch log of press hold on linksys phone.

techguy73 Tue, 06/01/2010 - 08:52

one command that I see you are missing is this:

ccm-manager music-on-hold

give it a try...

xaba-xaba Wed, 06/02/2010 - 01:29

Hello, techguy73!

Thank you for answer. I try it, but it's no help

I also try hear MOH from VLC player. I connected rtp:[email protected]:6061 and a HEAR MOH!! But, on LinkSys telephone - MOH not hear... What i do write in MOH server parametr on LinkSys? I write there 224.168.168.168:6061 - not OK... I try write ip-addres of CME (192.168.1.250) - not ok also..

How play multicast MOH on linksys?

etmarcof Thu, 03/22/2012 - 11:48

Hi Xaba-Xaba,

Just one question regarding pickup with linksys SPA942.

have you pickup working with linksys SPA942 and CME?

Should i have to config ?

fac custom pickup local *36 !it's for pick-up service on linksys

fac custom pickup group *37

Also for linksys SPA942 should i config  type 7906 under voice register pool 1?

Best Regards,

MC

Actions

This Discussion