QPM 4.0 - Can't see the snmp strings for devices.

Unanswered Question
Jul 26th, 2007

Hi, I upgraded from 3.2.3 to 4.0 and imported the 3.2.3 devices and policies. I ran a discovery on the devices and found that 8 reported snmp errors. When I went to check the access configuration of a device, I found that the only fields are "Blind Login" and "Use SSH Connection". There is no fields for snmp strings, TACACS etc. I checked my permissions and I have everything ticked.

Any ideas?

Cheers, SteveK.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Joe Clarke Sat, 07/28/2007 - 17:09

These permissions are found under the Common Services DCR section. That is, Common Services > Device and Credentials > Device Management.

stevek1 Mon, 07/30/2007 - 14:31

Thanks Joe,

Given that I knew my LMS DCR was an accurate inventory of my devices, I set QPM to act as a DCR Slave to it, to ensure I got all the correct credentials. The problem is that LMS tools identify the devices via the "Display Name" whereas when you import the devices into QPM, it uses the "Host Name" which happens to be the IP address of the device. Is there any way to globally change the "Host Name" field in my LMS DCR to use DNS and display as the real host name?

Thanks, Steve.

Joe Clarke Mon, 07/30/2007 - 15:47

There is no way to make global identity changes in DCR. Campus Device Discovery should handle updating the DCR hostname field when new hostname values are found, but the display name will not be updated unless the nameserver.updateDCRDisplayName is true in NMSROOT/campus/etc/cwsi/DeviceDiscovery.properties.

stevek1 Mon, 07/30/2007 - 15:51

Joe, Are you saying Campus should be updating DCR with the reverse lookup hostname on my LMS server, because all the devices have IP addresses in the "Host Name" field?


stevek1 Mon, 07/30/2007 - 21:46


I've manually changed all the devices in the Master DCR to have hostnames in the relevant field. However, when I try to import them into QPM on the Slave box, the devices are still listed by IP addresses.


Joe Clarke Mon, 07/30/2007 - 23:09

This seems to be a bug in QPM. When you do actually import the devices, though, they will appear by hostname in the QPM managed device list.

Joe Clarke Mon, 07/30/2007 - 23:08

Provided the addresses can be properly resolved (using NMSROOT/bin/resolver.pl) then Campus should be updating DCR with the correct information.

stevek1 Tue, 08/07/2007 - 14:34


When I import the devices into QPM from DCR, they keep failing with a telnet error. If I test SSH access to the device from the CiscoWorks Device Center, it's OK. It seems QPM is not trying to use SSH. So I checked the QPM Access Configuration and SSH is selected.

Any ideas? Steve.

Joe Clarke Tue, 08/07/2007 - 16:35

What is the specific error you are receiving? QPM does not use the same underlying code that Check Device Attributes uses (unfortunately), so there may be an issue if telnet is disabled on the device.

stevek1 Tue, 08/07/2007 - 16:44

Hi Joe,

Pls see attached screen dump.

I have edited the credentials in Common Services and I feel there is no reason it shouldn't work. Steve.

Joe Clarke Wed, 08/08/2007 - 03:58

What version of SSH do these devices support? You can easily find this out by telneting to TCP port 22, and looking that the version info:

1.5 : SSHv1

1.99 : SSHv1 and v2

2.0 : SSHv2

Currently, since QPM 4.0 does not use the same command services code that RME uses, it only supports SSHv1. So if the device is configured for v2 only, QPM 4.0 will not work with it.

SSHv2 support for QPM 4.0 is planned for the next release coming by the end of this year.

stevek1 Wed, 08/08/2007 - 15:23

Here is the output Joe....


Regards, Steve.

Joe Clarke Wed, 08/08/2007 - 19:36

You will need to add:

ip ssh version 1

To this device in order for QPM to be able to connect to it.


This Discussion