Vlan questions

Unanswered Question
Jul 27th, 2007
User Badges:

I'm in the process of setting up vlan on our 3750 Cisco switches I need 14 vlans our network addresses starts with 10.10.0.0/22 (10.10.4.0/22, 10.10.8.0/22, 10.10.12.0/22??)

When I configure the vlan like this everything work correctly I get handed a DHCP address, I can browse the internet it all works. But I cannot create the next vlan because it overlaps the Netmask of 255.255.0.0

--------------

!

interface Vlan305

ip address 10.10.12.1 255.255.0.0

ip helper-address 10.4.48.1

ip helper-address 10.4.55.18

!

router rip

network 10.0.0.0

!

ip classless

ip default-network 10.0.0.0

ip route 10.0.0.0 255.0.0.0 10.4.9.1

ip http server

!

----------------

The problem is I need to have it set up like this with a Netmask of 255.255.252.0 but when I do nothing works, no DHCP no internet, no login..

---------------

!

interface Vlan305

ip address 10.10.12.1 255.255.252.0

ip helper-address 10.4.48.1

ip helper-address 10.4.55.18

!

interface Vlan310

ip address 10.10.16.1 255.255.252.0

ip helper-address 10.4.48.1

ip helper-address 10.4.55.18

!

router rip

network 10.0.0.0

!

ip classless

ip default-network 10.0.0.0

ip route 10.0.0.0 255.0.0.0 10.4.9.1

ip http server

!


Any ideas where I'm going wrong?


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mohammedmahmoud Fri, 07/27/2007 - 04:25
User Badges:
  • Green, 3000 points or more

Hi,


What is this switch running RIP with, can you please add "version 2" and "no autosummary" under router rip, and if "10.4.9.1" is your default gateway why not using a normal default route pointing to it.


HTH,

Mohammed Mahmoud.

albolabris Fri, 07/27/2007 - 04:43
User Badges:

Hi Mohammed,

The switch does not need to be running rip (this is left over from previous testing). What do you mean by "normal default route pointing to it."?


mohammedmahmoud Fri, 07/27/2007 - 04:45
User Badges:
  • Green, 3000 points or more

Hi,


Ok then go like this:


no router rip

no ip default-network 10.0.0.0

no ip route 10.0.0.0 255.0.0.0 10.4.9.1


ip route 0.0.0.0 0.0.0.0 10.4.9.1



HTH,

Mohammed Mahmoud.

Pavel Bykov Fri, 07/27/2007 - 04:48
User Badges:
  • Silver, 250 points or more

like "ip route 0.0.0.0 0.0.0.0 10.4.9.1" without actually running RIP.

albolabris Fri, 07/27/2007 - 04:59
User Badges:

That's done, here's the new config

------------

!

interface Vlan305

ip address 10.10.12.1 255.255.0.0

ip helper-address 10.4.48.1

ip helper-address 10.4.55.18

!

ip classless

ip default-network 10.0.0.0

ip route 0.0.0.0 0.0.0.0 10.4.9.1

ip http server

!

------------------

I'm still having the same problem when I change the Netmask to 255.255.252.0

mohammedmahmoud Fri, 07/27/2007 - 06:50
User Badges:
  • Green, 3000 points or more

Hi,


Please post the whole configuration, and please do remove the "ip default-network 10.0.0.0" and can you clarify how is 10.4.48.1 and 10.4.55.18 connected to the switch, and finally please describe your addressing scheme.


HTH,

Mohammed Mahmoud.

albolabris Fri, 07/27/2007 - 08:01
User Badges:

Mohammed


Our network is dumped into vlan 1 right now.

10.4.48.1 is the Novell DNS/DHCP server.

10.4.55.18 is the Novell Zenworks Imaging server.

10.4.9.1 is the gateway on the Juniper ISG-1000.

DHCP is set up for just about everything in the 10.4.0.0 range


Also now that I removed rip and ip default-network 10.0.0.0 and changed ip route 10.0.0.0 255.0.0.0 10.4.9.1 to ip route 0.0.0.0 0.0.0.0 10.4.9.1 Vlan 305 is no longer working...


The config sheet is attached...




Attachment: 
mohammedmahmoud Fri, 07/27/2007 - 08:09
User Badges:
  • Green, 3000 points or more

hi,


From the configuration you've attached, you need to create the required VLANs (can you please post a show vlan), then you need to configure a SVI interface for each VLAN (interface vlan x) and give it the appropriate IP address and finally you need to assign each vlan on the appropriate interface(s) using the " switchport access vlan 100" command.


Please if you wish list all your requirements neatly and clarify your network topology and lets configure it.


HTH,

Mohammed Mahmoud.

albolabris Fri, 07/27/2007 - 09:08
User Badges:

Mohammed


Our whole network is dumped into vlan 1 right now.

10.4.48.1 is the Novell DNS/DHCP server.

10.4.55.18 is the Novell Zenworks Imaging server.

10.4.9.1 is the gateway on the Juniper ISG-1000.

DHCP is set up for just about everything in the 10.4.0.0 range


What I would like to do right now is to get this one vlan working (305)


I have two switches set up right now

10.4.10.10 and 10.4.10.12 they are connected by Cat5

10.4.10.10 port gi1/0/32 is connected to 10.4.10.12 Port gi1/0/39

I have 1 workstation set up into Vlan 305 it is on 10.4.10.12 port gi1/0/21


I need this one workstation in vlan 305 to be able to access the internet (10.4.9.1) as well as communicate with the Novell servers (10.4.55.18)


I've attached the config sheets for both switches as well as "sh vlan" for both switches...



Actions

This Discussion