CSM @ Layer 2

Unanswered Question
Jul 27th, 2007

Hello,

I have a simple SLB configuration running in RP mode. If a client on the same network as the virtual IP tries to connect to the VIP, it fails. I'm guessing this is because the communication is done at layer 2 and the packet never gets sent to the router to receive the SLB instruction. Is there a way around this or a way to fix this?

Thank you,

Scott

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Gilles Dufour Mon, 07/30/2007 - 03:47

when the client is in the same subnet as the server, you need to enable client nat so that the response from the server goes back to the loadbalancer and not directly to the client which would reject the response coming from the server ip.

Gilles.

Actions

This Discussion