ospf route selection

Unanswered Question
Jul 29th, 2007

Hello,

Attached please find my OSPF diagram.

R3 in area13 has two link connected area0 via separate ABR(R1 & R2), the backup tunnel has been set a higher interface cost to insure it will not be choosed if the SDH is UP.

Actually i found the route 10.13.0.0/16 in R1 was correctly choosed SDH as next-hope, but R2 choosed the backup tunnel directly even if the route metric is higher. In my idea, the R2 should choose R1 as next-hope and via SDH to reach 10.13.0.0/16.

If i shutdown the backup tunnel manually, R2 will choose R1 as next-hope for the route 10.13.0.0/16.

I must got some misunderstand in the OSPF area design, anyone help to clarify will be much appreciated.

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
balajitvk Sun, 07/29/2007 - 02:14

Hi,

The attached document couldn't be opened.

See atleast whether the R1 picks r2 whenever the SDH getting failed.

Moreover can you share the config of routers to analyse further.

Rgs,

flymen331 Sun, 07/29/2007 - 03:07

Hi,

Attached please find my config and diagram. Thanks for you reply!

-----------------R2 config------------------

router ospf 1

router-id 10.1.0.2

log-adjacency-changes

redistribute static metric 10 metric-type 1 subnets

passive-interface default

no passive-interface FastEthernet0/0

no passive-interface Tunnel4001

network 10.1.0.0 0.0.0.15 area 1

network 1.1.1.48 0.0.0.3 area 13

!

interface Tunnel4001

description Backup Tunnel

ip address 1.1.1.49 255.255.255.252

ip mtu 1476

ip tcp adjust-mss 1436

ip ospf cost 1000

keepalive 10 3

tunnel source 192.168.9.10

tunnel destination 192.168.9.2

end

!

interface FastEthernet0/0

description connected to R1

ip address 10.1.0.2 255.255.255.240

ip ospf cost 10

!

------------------R1 config--------------------

router ospf 1

router-id 10.1.0.1

log-adjacency-changes

redistribute static metric 10 metric-type 1 subnets

passive-interface default

no passive-interface FastEthernet0/0

no passive-interface FastEthernet0/1

network 10.1.0.0 0.0.0.15 area 1

network 10.13.0.0 0.0.0.3 area 13

!

interface FastEthernet0/0

description connected to R2

ip address 10.1.0.1 255.255.255.240

ip ospf cost 10

!

interface FastEthernet0/1

description connected to R3 via SDH

ip address 10.13.0.1 255.255.255.252

ip ospf cost 10

!

------------------R3 config--------------------

router ospf 1

router-id 10.13.0.2

log-adjacency-changes

redistribute static metric 10 metric-type 1 subnets

passive-interface default

no passive-interface FastEthernet0/0

no passive-interface Tunnel1001

network 10.13.0.0 0.0.0.3 area 13

network 1.1.1.48 0.0.0.3 area 13

!

interface FastEthernet0/0

description connected to R1

ip address 10.13.0.2 255.255.255.252

ip ospf cost 10

!

interface Tunnel1001

description Backup Tunnel

ip address 1.1.1.50 255.255.255.252

ip mtu 1476

ip tcp adjust-mss 1436

ip ospf cost 1000

keepalive 10 3

tunnel source 192.168.9.2

tunnel destination 192.168.9.10

end

!

ip route 10.13.0.0 255.255.0.0 Null 0

Attachment: 
balajitvk Sun, 07/29/2007 - 03:31

Hi,

In your design, R2 will naturally pick its nexthop thro. tunnel interface for the area0 or inter-area routes becz always an intra-area route is always preferred to a inter-area route regardless of metric and also R2 itself is the ABR for the inter-area routes.

But R3 might choose R1 as a nexthop becz of your cost configurations.

Rate if it does,

Rgs

flymen331 Sun, 07/29/2007 - 04:47

Hi balajitvk ,

Really appreciate your help!

I will consider to migrate the backup tunnel to R1. But is there any way to control the route selection if the backup tunnel still in R2.

Thanks!

GillieLucent Tue, 07/31/2007 - 23:20

Hi,

1) Adding a static route in R2 with R1 as next-hop will work. But, if link between R1 and R3 goes down, you need to change again.

2) Configure some other protocol like RIP between R2 and R3, in that case R2 prefers R1.

Correct me if I am wrong.

Thanks,

Vijaybabu

Actions

This Discussion