HELP PLEASE!!

Unanswered Question
Jul 29th, 2007

Hi,

I have a multilayer Cisco 3560 network. All sites are connected to each other using RIP V2.

1. We have remote sites connected by microwave links using Cisco 3560.

2. In the attached image "Site-1" should get an IP from the HeadOffice DHCP Server. They also should get the internet connection from DHCP.

3. HEAD OFFICE switch is running the VTP Domain.

Question

1. I have rip version 2 running. How do I get "SITE-1" to get an IP Address from the DHCP Server running in Head Office.

Kindly give me your expert comments/suggestions in how do I go about achieving the above.

Regards

Sarfaraz

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Ahmede Sun, 07/29/2007 - 05:26

On STE-1 switch, use ip-helper address command.

HTH,

Ahmed

sarfarazkazi Sun, 07/29/2007 - 05:36

Dear Ahmed,

I have tried that but it doesnt work. I even tried changing the vlan configuration to "ip address dhcp" to test it but I was unable to get any IP. Attached is the configuration for both the sites.

Attachment: 
manmeetmarwah Sun, 07/29/2007 - 05:45

Dear Friend,

You need to assign an IP address to your interface vlan 1. Also I can see that your interface VLAN 1 is down, you need to issue command " no shutdown" on interface VLAN 1. I would suggest you to do the following:

1) Assign an IP address to interface VLAN 1, it should be of the same subnet as you want for the clients of VLAN 1 to be in.

2) Put the command "ip helper-address 172.20.109.1" on interface vlan 1. I have assumed that 172.20.109.1 is your DHCp server at head office.

3) Connect one PC to a port in VLAN 1 to verify the DHCP functionality.

4) Also you need to ensure that you are able to ping the DHCP server from the switch.

Manmeet

*Pls rate if helpful

sarfarazkazi Sun, 07/29/2007 - 05:51

Dear Manmeet,

When I am putting the same subnet IP address on Site-1 "Vlan-1" i.e. 172.20.109.51, I am unable to ping the HeadOffice 172.20.109.1. when I am removing the IP from Vlan-1 I can ping 172.20.109.1.

manmeetmarwah Sun, 07/29/2007 - 06:00

Hi friend,

I haven't told you to put the same subnet IP address. I wanted to say that you should put a new subnet ip address which would be recognised by the dhcp server and then dhcp server would send back the ip addresses to the clients.

Eg config:

interface vlan 1

ip address 10.20.20.1 255.255.255.0

ip helper-address 172.20.109.1

no shutdown

In the above example I have assumed that you need to assign the Ip addresses to the clients at site 1 with Ip addresses in the subnet 10.20.20.0/24

Also you should not give 172.X.X.X IP to your any other interface vlan.

Hope the above clarifies your doubt.

manmeetmarwah Sun, 07/29/2007 - 06:15

Just wanted to simplify that you need to put the IP subnet on interface VLAN 1 for which the scope configuration has already been done in your DHCP server.

You might need to ask the DHCP server guy regarding the IP subnet to be assigned to Site 1 clients and then should configure one IP address from that subnet to your interface VLAN 1.

Manmeet

* Pls rate if helpful

sarfarazkazi Sun, 07/29/2007 - 06:49

Dear Manmeet, Thanks for your reply. I had tried the following:-

Gave IP 172.20.222.1/24 on vlan 1. I also issued the ip helper-address 172.20.109.1 on vlan 1. However as you pointed out there was no scope of 172.20.122.x/24 defined on the server. I will try this out and get back to you.

Just a question. Why can't I use 172.20.109.x?

manmeetmarwah Sun, 07/29/2007 - 21:03

You are always welcome!

The reason why you can't use 172.20.109.X network on site 1 is bcoz you are already using this network at your HO and moreover you are running routing between the sites. Thus in a WAN network, you can't have same subnets on different segments.

Manmeet

* Pls rate if helps

sarfarazkazi Mon, 07/30/2007 - 00:00

Dear Manmeet,

Now I am facing another problem. I am able to get the IP address from the Head Office but I have no internet now. I can ping all the vlans at the HO. But when I am doing a traceroute from a PC to the internet it stops at the VLAN I have defined at Site-1.

int vlan 1

ip address 192.168.100.1 255.255.255.0

ip helper-address 172.20.110.12

router rip

version 2

network 10.0.0.0

network 192.168.100.0

Do I need to add a default route?

Regards

Sarfaraz

manmeetmarwah Mon, 07/30/2007 - 00:57

Hi Sarfaraz,

Yes that's true that you need to put a default route in your switch towards next hop which would be 10.10.10.2 ( as per the diagram). I wonder that if you would have used restribution in the HO switch for static routes, each site would have got that automatically. Anyways you should put a default route towards next hop.

Moreover you may also need to do the reverse routing at central site setup. I would not be able to comment till the time you can send me INternet setup diagram and configs.

Firstly, just check the same by adding default route.

ip route 0.0.0.0 0.0.0.0 10.10.10.2

Manmeet

*Pls rate if helps

sarfarazkazi Mon, 07/30/2007 - 02:57

Dear Manmeet,

I will have to add a default route on each site. At the HO L3 switch I have a default route pointing towards the DSL. The DSL is a cisco 97. My question is what redistribution command will I give on the HO switch?

manmeetmarwah Mon, 07/30/2007 - 06:18

Dear sarfaraz,

Further to amit's comment you should add the following command under "router rip"

redestribute static metric 1

I would suggest the above command as it (metric 1)gives you scalability for future purposes as you may add more hops and would like to advertise the default route to these hops also.

Manmeet

*Pls rate if helpful

Actions

This Discussion