SFP integrity check with 4506 GB-T

Unanswered Question
Jul 29th, 2007

I recently found out something weird with the GLC-SX-MM= modules on the 4506-GB-T line card.

When i change the media type to RJ-45 and remove the GBIC from the port and insert it on any other port on the line card, i get an SPF serial integrity check failure and the port stops forwarding packet. It does not resume even after doing a shut or noshut. Rebooting the switch is the only alternative to revive the port

This does not seem to be a problem if the port was configured to be a media type of SFP and the same action was performed.

So if i want to remove the GBIC from the port and eventhough the media-type is RJ-45, you need to reverse the media type to SFP, remove it and configure it back to RJ-45.

This seems to be very strange as these modules are hot swappable but you end up needing a downtime in the above case.

Is this some sort of limitation that i could not find out in CCO?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
ankbhasi Sun, 07/29/2007 - 21:42

Hi Narayan,

Is it possible for you to post the version of code you are running on your sup and also exact and full error message which you observe?



royalblues Sun, 07/29/2007 - 23:50

Ankur, here you go

Code running is 122-25.EWA9

here is the error message


00:15:17: %C4K_CHASSIS-3-SFPSERIALINTEGRITYCHECKFAILED: SFPs on ports Gi4/1 and Gi4/2 have duplicate serial numbers

00:15:17: %C4K_IOSINTF-5-RJ45INACTIVE: Slot= 4 Port= 2: RJ45 connector has become inactive

00:15:33: %C4K_IOSINTF-5-GBICINSERTED: Slot= 4 Port= 2: GBIC has been inserted


ankbhasi Mon, 07/30/2007 - 00:40

Hi Narayan,

As we all know these modules are hot pluggable so there should not be any problem when it is switches from one port to another.

The error message which we get because of duplicate serial number can be because of cloned SFP SEEPROM. Can you confirm if it is Cisco SFP module also have you tried using different SFP module and is the same error reported? I mean can you reproduce this problem with another SFP module?

If another SFP module also gives the same error is it possible for you to reseat that specific line card once or may be power that specific line card and bring that back up.



royalblues Mon, 07/30/2007 - 00:53

Yes my dear friend, it is a cisco GBIC only.

This happens will all the modules. I was testing something and found this strange behavior.

As is sadi earlier, if you change the media-type to SFP and do the same thing, you do not get this error.

This means i need to be sure to remove the modules before turning them back to RJ-45 otherwise request a downtime for this if need to do this later:-)


royalblues Wed, 01/02/2008 - 07:20

Here's a Cisco TAC update on the issue, Might help if someone runs into the same issue :-)

TAC Response


I found a separate internal software failure with the following title.

Duplicate seeprom error when SFP moved rapidly between ports

Within this internal document I saw the following workaround.

When moving the SFP from fort 1 to port 2 please wait at least 10-20 seconds.




This Discussion