SIP Trunk Configuration - CUCME 4.1 + ITSP

Unanswered Question

Hello,

I have been toying with my CallManager Express for a while now and could not get SIP trunking to work properly. First of all, my ITSP requires that we use a different DNS host when sending/recieving messages to their SIP server, but also they are using port 5065. I haven't found any documentation to make this work... anyone have any ideas?

Also, everytime I try to set a registrar in sip-ua, it seems ALL my dial-peers are trying to register with the SIP server (I am sending REGISTERs for my 9....... entries and whatnot). I tried playing with dialplan-pattern but I guess I'm not doing this properly.

So here's my setup:

- SIP Phone number is 1XXXYYY3600

- SIP server is located at nat.babytel.ca

- SIP server wants to recieve requests/registers using sip.babytel.ca

- SIP traffic MUST be sent to nat.babytel.ca port 5065

- All my extensions are between 5000 and 5999

I want this phone number to terminate on the CUE AA. My Attendant number is 5601. I can build a dial-peer that matches 3600 if need be.

Here is what show sip-ua register status is showing when I put my registrar in the sip-ua config:

ccme#show sip-ua register status

Line peer expires(sec) registered

============ ============= ============ ===========

1XXXYYY3600 -1 0 no

5101 20001 0 no

5201 20002 0 no

5202 20003 0 no

5203 20004 0 no

5301 20011 0 no

5302 20012 0 no

5701 20007 0 no

5702 20008 0 no

5703 20009 0 no

5704 20010 0 no

5800.... 20005 0 no

5801.... 20006 0 no

Why are they showing up for no reason? Have I forgotten something in my configuration?

Thanks for helping.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Sun, 07/29/2007 - 15:47

First of all I would switch ITSP as they are too demanding :)

Jokes apart everything should work fine. Under sip-ua:

sip-server ipv4:sip.babytel.ca:5065

registrar ... ditto

username ... password ... realm ..

credentials ....

Under all ephone-dn ;

number ... no-reg

And yes, configure one ephone-dn with the number to be registered. This one will not have "no-reg".

Hope this helps, please rate post if it does!

Thanks, I'll try that - but where do I specify that I need to send traffic to nat.babytel.ca? The configuration you gave me will send REGISTER requests to sip.babytel.ca but not nat.babytel.ca...

In fact, ALL traffic should be sent to nat.babytel.ca but with sip.babytel.ca as a from:/to: domain.

About the no-reg thing, all my ephone-dn's have no reg but they still try to register! I'm at a loss...

As for being too demanding, I agree with you 100% :) Their setup is quite weird...

Paolo Bevilacqua Mon, 07/30/2007 - 01:05

Hi,

I'm not looking at the config for now, I will if this still don't work.

wrt the destination of sip signaling traffic, configure sip.babytel as they said. The address for media is specified each time in sip messages, you need not to worry about it, neither they should mention it explicitly.

To stop ephone-dn from attempting registering. try deconfigure them completely and configuring again. If that don't work, you need to reboot the router.

Paolo Bevilacqua Mon, 07/30/2007 - 09:29

No don't upgrade. Enable "term mon" and "debug ccsip message" for the registration issue.

For the pots peers, use "no sip-register". For the ephone-dn, "no-reg". As I said these are a bit stubborn and sometime you have to reconfig or reload stop the registration attempts.

I have finally got the trunk working, using the following workaround:

This provider requires all addresses to be formulated as ...@sip.babytel.ca but all traffic be directed to nat.babytel.ca. So I did "ip host sip.babytel.ca 216.18.125.7", and it was good.

I created an ephone-dn with my phone number and made it register; I also made an outgoing dial-peer (with appropriate calling-info in sip-ua) & everything works fine now! Except...

Here are my two problems:

Most ephone-dn's still try to register to my provider even though they all have a no-reg both directive. I am still stumped on that one...

The other issue is that there is no ringback after CUE transfers a call to one of my phones, and DTMF ceases working when I terminate on a voicemail box after a forward-no-answer or a forward-busy condition. DTMF works fine in my AA though. It does not when talking to a voicemail. The second the call leaves the CUE AA, I lose ringback & DTMF capabilities. I have verified this condition because I have a separate .aef file which is being called by a special transfer rule in my AA script.

Any ideas?

Paolo Bevilacqua Mon, 07/30/2007 - 23:23

If you do "ip host ..." or configure the ip address directly under sip-ua, it's exactly the same thing ...

Have you rebooted the router and the ephone-dn still tries to register ?

For the hostname part, it's somewhat of a weird requirement for Babytel... I've tried the aforementioned configuration to no avail, the host method works. The other workaround would be to define an outbound-proxy but that would break CUE integration.

As for the ephone-dn's, yes I have done a reload and a hard reboot and neither will clear this condition.

Paolo Bevilacqua Tue, 07/31/2007 - 07:19

Hi,

When you do "ip host " and then "sip-server dns:", that is perfectly equivalent to "sip-server ipv4:". In neither case a DNS request is actually made. I'm saying that just to clarify how the IOS works.

For the stubborn registration, can you send again the config abridged as necessary ?

Actions

This Discussion