Etherchannel

Unanswered Question
Jul 30th, 2007
User Badges:

I have connected 2 switches together using just one interface - 100MB, now I want to create an Etherchannel of 4 interface so that can have 400MB. As these switches are live, if I start to put the extra 3 interfaces into a channel group, will there be a downtime?


Also o the new switches, can use more than 4 interfaces to get an etherchannel?


Thanks


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
graemeporter Mon, 07/30/2007 - 02:15
User Badges:
  • Bronze, 100 points or more

Hi there,


I believed you can have up to 8 ports in each channel group. These can be a mix of different media; for example, you can have some SFP GBICs and some gigabit RJ45 interfaces in the same group. Not sure about mixing FastEthernet and GigabitEthernet though.


For a live environment, I'd recommend doing this under whichever change control process you use within your organisation as changes between switches can be risky, even if this does not cause an outage. Better safe than sorry!


Whether or not an outage will result, though, I'm not sure. I'm guessing your single port connection is not part of any EtherChannel group, correct?


I'm not certain, but if it's not, I think that adding it to a group may cause a spanning-tree recalculation. Adding additional ports to the group should not cause additional outages.


Hope this helps!


Kind regards,

Graeme

michal.grzelak Mon, 07/30/2007 - 02:54
User Badges:

Hi,


I was adding the new ports to channel, but always with console connection to both devices. That is why I wouldn't recomand reconfiguring the port-channel without backup/failover connection. When two switches will not negotiate channel parameteres, You may be cut off.

Following is the configuration that I am using and thus I can recommand it as safe:


interface GigabitEthernet1/1

description switchB_link1

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

logging event spanning-tree status

logging event bundle-status

logging event trunk-status

speed 1000

duplex full

channel-protocol lacp

channel-group 1 mode active

!

interface GigabitEthernet1/2

description switchB_link2

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

logging event spanning-tree status

logging event bundle-status

logging event trunk-status

speed 1000

duplex full

channel-protocol lacp

channel-group 1 mode active

!

interface Port-channel1

description switchB

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

logging event spanning-tree status

logging event bundle-status

logging event trunk-status

no shut


If You have any more questions, please let me know:


Regards:

Michal

chitre_salil Mon, 07/30/2007 - 21:00
User Badges:

Hi,


Check switch port capabilities. It shows which ports can form a etterchannel. There are restrictions on some older switches like the 5509.


Thanks

Salil



londint Mon, 07/30/2007 - 23:01
User Badges:

Thanks. How do you check port capability on Cisco IOS. I keep seeing Show port capability but it only works on CatOS. Thanks

Jon Marshall Mon, 07/30/2007 - 23:11
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Hi


sh interfaces "interface" capabilities


HTH


Jon

Actions

This Discussion