AS5400 / cc terminal problem when speaking to a server

Unanswered Question

Hi there,


When I dial from cc terminal into my as5400 box, it tries to speak to the authentication server which is on the LAN. However, the connection is rejected by the server due to unexpected error.

I've managed to capture the traffic using ethereal, then had a chat with our developers. They identify the problem saying:


"

there is something wrong with the router as it sends useless characters (lots of 0x91 0x11 bytes) and sends them one by one instead of a whole frame.

"


Indeed, all the frames sent by as5400 are 60bytes long - why?


Is it possible to debug the as5400 to analyse incoming frames from the terminal and see how they're transformed before being sent to the server?



Thanks,


Paul

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Mon, 07/30/2007 - 13:53
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

What protocol do they "speak", IP ?

What is CC ?

The minimum legal length for ethernet is 60 bytes, that is why you see that.

paolo bevilacqua Tue, 07/31/2007 - 00:18
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

What exact protocol ? How is the router configured ? It will normally send all the characters received by the CC terminal.

Here is the config...




Building configuration...


Current configuration : 4381 bytes

!

! No configuration change since last restart

!

version 12.4

service tcp-keepalives-out

service timestamps debug datetime msec

service timestamps log datetime localtime show-timezone

!

!

boot-start-marker

no boot startup-test

boot-end-marker

!

logging buffered 16000 debugging

!

!

!

resource-pool disable

no aaa new-model

clock timezone gmt 0

clock summer-time IRL recurring last Sun Mar 2:00 last Sun Oct 2:00

clock calendar-valid

spe default-firmware spe-firmware-1

no ip subnet-zero

no ip source-route

!

!

ip cef

no ip domain lookup

ip host SERVER 10.2.10.100

!

!

no ip bootp server

isdn switch-type primary-net5

modemcap entry PP4:MSC=&fd0

modemcap entry 5100C:MSC=&F&D2S22=0S23=0S24=1S21=3S0=1

!

!

!

!

!

!

!

controller E1 7/0

pri-group timeslots 1-31

!

controller E1 7/1

pri-group timeslots 1-31

!

controller E1 7/2

pri-group timeslots 1-31

!

controller E1 7/3

pri-group timeslots 1-31

!

!

!

interface GigabitEthernet0/0

ip address 10.2.10.6 255.255.255.0

no ip proxy-arp

ip ospf hello-interval 3

ip ospf dead-interval 10

ip ospf retransmit-interval 2

duplex full

speed 100

negotiation auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

negotiation auto

!

interface Serial0/0

no ip address

shutdown

clock rate 2000000

!

interface Serial0/1

no ip address

shutdown

clock rate 2000000

!

interface Serial7/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice modem

!

interface Serial7/1:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice modem

!

interface Serial7/2:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice modem

!

interface Serial7/3:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice modem

!

interface Group-Async0

no ip address

encapsulation slip

no group-range

!

interface Group-Async1

no ip address

encapsulation ppp

async mode interactive

no peer default ip address

ppp authentication chap radius-ppp

group-range 1/00 1/107

!

!

ip tacacs source-interface Loopback0

no ip http server

!

!

!

!

control-plane

!

!

!

voice-port 7/0:D

!

voice-port 7/1:D

!

voice-port 7/2:D

!

voice-port 7/3:D

!

!

!

!

ss7 mtp2-variant Bellcore 0

ss7 mtp2-variant Bellcore 1

ss7 mtp2-variant Bellcore 2

ss7 mtp2-variant Bellcore 3

!

line con 0

stopbits 1

line aux 0

stopbits 1

line vty 0 4

login

line 1/00 1/107

no motd-banner

no exec-banner

exec-timeout 0 0

no flush-at-activation

script modem-off-hook offhook

no vacant-message

modem InOut

modem autoconfigure type 5100C

autocommand connect SERVER 2600 /stream

no activation-character

exec-character-bits 8

special-character-bits 8

no history

no editing

transport preferred none

transport input all

transport output lat pad telnet rlogin udptn v120 lapb-ta

escape-character NONE

no ip tcp input-coalesce-threshold

!

scheduler allocate 10000 400

end


paolo bevilacqua Tue, 07/31/2007 - 05:20
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hello,


You have /stream, means the router is sending what is receiving. Check again the captured frame and the TCP payload length (not total frame length). Is error correction enable and working with the CC modem ?


paolo bevilacqua Tue, 07/31/2007 - 06:51
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


You can debug what the modem sends and receive with "debug modem traffic". be aware that if you have many calls it can produce a lot of traffic so try to limit and log to buffer.

This way it should be possible to prove that the bytes you mentioned above are being received verbatim from the CC modem.

Actions

This Discussion