×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Configuring a terminal server - problem

Unanswered Question
Jul 30th, 2007
User Badges:

Hi


I started configuring a 2511 as a terminal server. I have a problem with the following command:


line con 0

logging synchronous

login

transport input none


I can't give this command, because I can't give the command, "transport input' because in my router I don't have 'input option. Instead what I have is 'output' option. Then if I'm to give this command I will have to say, 'transport output none'


I have two octal cables connected to the 2511 (which is the terminal server I'm configuring) and the RJ45 ends to the other routers.




I have another problem in the following command as well:


line 1 4

session-timeout 20

no exec

exec-timeout 0 0

no flush-at-activation

logging synchronous

modem InOut

transport input all

line 5 16

session-timeout 20

no exec

exec-timeout 0 0

no flush-at-activation

modem InOut

transport input all



when I give these command, I get a message saying that, 'Line 2 does not supprt modem control' and 'Line 5 does not support modem control'


However after finish configuring, when I telnet to the terminal I am suppose to asked for a username, because I give the following command:


username p1r1 nopassword


username p1r1 autocommand resume 10.0.0.101 /connect telnet 10.0.0.101 2001


But, may be because I get those error messages I do not get the screen, which asks me the username. When I telnet to the terminal server, I don't get anything on the screen and screen turns off in a few seconds, as if I'm trying to telnet without configuring a password.


I have used the same configuration at office. Then it works just fine.


I am very concerned about the two error messages I get and why I get them. Can you please explain why and give me a solution to over come this situation and to make it up and running.


Thanks a lot in advance!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
mohammedmahmoud Mon, 07/30/2007 - 05:53
User Badges:
  • Green, 3000 points or more

Hi,


Please follow the following (and note that you don't need anything mandatory under the consoles)


under the serial interface (If A/S):

--> physical-layer async

--> async mode interactive


under the async TTY line(s):


--> transport input telnet

--> stopbits 1


NOTE: "no exec" under the lines - Unwanted signals from the attached device do not launch. An EXEC session ensures that the line never becomes unavailable due to a rogue EXEC process.


and connect the cables to the console of your devices using the Octal male DB-68 (SCSI II) connector (CAB-OCTAL-ASYNC), since the CAB-OCTAL-ASYNC cable is itself rolled, you can connect each cable directly to the console ports of devices with the RJ-45 interfaces.


Issue this command to establish a reverse Telnet connection from your terminal server - console server - comm server:


telnet x.x.x.x 2yyy or [2000+yyy]


The x.x.x.x represents the IP address of any up/up interface on the Cisco router (recommended to be a Loopback) and yyy is the line number to which you want to connect (5 = 005). If you have already configured the TTY line, you can issue the telnet command from anywhere on the network that can ping the x.x.x.x interface.


To get yyy do "show line" and then add the number to 2000 thats how you get the 2yyy number (port number) to use to reverse telnet, ex: for line 5 use 2005.


Each line corresponds to an RJ-45 cable and thus to one of your devices.


To disconnect, hit Ctrl-Shift-6 and then x to get back to the router prompt and then type in disconnect to close the connection.


To add an Alias for each of your devices:


ip host

ex: ip host 3600-2 2013 172.21.1.1



HTH,

Mohammed Mahmoud.



omal Mon, 07/30/2007 - 09:57
User Badges:

Hi Mahmoud


Many thank for your detailed clarification.


I can't give the command 'no exec'. The moment I give that command I don't see anything when I telnet. But without 'no exec' command under line 1 16 I get the option to enter the username. I configured it like this:


username r1 nopassword


username r1 autocommand resume 10.0.0.101 /connect telnet 10.0.0.101 2001



Oh and by the way, I telnet from the LAN. I don't configure serial interfaces. I go in through ethernet port.


Now the problem is, when I telnet I can enter the username. Then I enter the username as 'r1'. Then it says, 'Trying 10.0.0.101 ... 2001 open'


but it never logs in to the other router via console port. I use the same setup at a different place and it works there.


Any advice???????


Many thanks in advance.

mohammedmahmoud Mon, 07/30/2007 - 13:10
User Badges:
  • Green, 3000 points or more

hi,


I think that the problem is in the "resume 10.0.0.101 /connect telnet 10.0.0.101 2001".


Can you please post all your routers relevant configuration.


HTH,

Mohammed Mahmoud.

omal Wed, 08/01/2007 - 08:52
User Badges:

Hi Mahmoud


Below is the configuration. And you know something I tried it with another 2511 router. It worked.


My main problem in the router that it doesn't work, is that in that router the I get the following two errors.


error (1)


in line console 0.


(config)#line con 0

(config-line)#tranport ?

output

preferred


But I should get an option called 'input' in here. I don't get that. Do you know why?



error (2)


(config)#line 1 4

(config-line)#modem InOut

error: Line 2 does not support modem control



Why I get an error like that. I don't get it in any other routers. Is it a hardware problem?


I think mainly due to these two errors that I'm getting I can't properly configure the terminal server (router). Do I have to activate something to be able to issue those two commends or can it be a hardware error?


Please see below for my complete configuration.


Many thanks mahmoud!







2511#sh run

Building configuration...


Current configuration : 3195 bytes

!

version 12.2

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 2511

!

logging rate-limit console 10 except errors

enable password cisco

!

username Tim privilege 15 password 0 cisco


username r1 nopassword

username r1 autocommand resume 10.0.0.101 /connect telnet 10.0.0.101 2001

username r2 nopassword

username r2 autocommand resume 10.0.0.101 /connect telnet 10.0.0.101 2002

username r3 nopassword

username r3 autocommand resume 10.0.0.101 /connect telnet 10.0.0.101 2003

username r4 nopassword

username r4 autocommand resume 10.0.0.101 /connect telnet 10.0.0.101 2004

username r5 nopassword

username r5 autocommand resume 10.0.0.101 /connect telnet 10.0.0.101 2005

username r6 nopassword

username r6 autocommand resume 10.0.0.101 /connect telnet 10.0.0.101 2006



ip subnet-zero

no ip finger

no ip domain-lookup

!

no ip dhcp-client network-discovery

!

!

!

!

interface Loopback1

ip address 10.0.0.101 255.255.255.0

!

interface ethernet 0

ip address 192.168.1.254 255.255.255.0

!

interface Serial0

no ip address

shutdown

!

interface Serial1

no ip address

shutdown

!

ip kerberos source-interface any

ip classless

no ip http server

!

!

!

line con 0

logging synchronous

login

transport input none

line 1 4

session-timeout 20

no exec

exec-timeout 0 0

no flush-at-activation

logging synchronous

modem InOut

transport input all

line 5 16

session-timeout 20

no exec

exec-timeout 0 0

no flush-at-activation

modem InOut

transport input all

line aux 0

password cisco

logging synchronous

login

line vty 0 4

exec-timeout 20 0

logging synchronous

login local

line vty 5 15

exec-timeout 20 0

logging synchronous

login local

!

end

Actions

This Discussion