7206VXR Throughput problems.

Unanswered Question
Jul 30th, 2007
User Badges:

Hello


I seem to have a bit of a problem with my 7206VXR Router.

I have a few customers (about 30 or so) behind the router on wifi, adsl and fibre.

Now when I do a speed check against a reliable speedometer, or I download a file from my own computer (which is not behind this router, and on a 50Mbit line) I get between 1Mbit and 1.5Mbit, both upstream / downstream.

I have a spare 7206VXR (old boxes, you never know..) and I get exactly the same rates with identical config.

I've yelled at my isp, rattled the warhammer. But they insist there's more speed available.

So, tonight I took my laptop, removed the router, and did a speed test.

30mbit downstream / 20Mbit upstream, with no router present.


Damn.


So, I removed my routerconfig, and tuned it with a simple, down-to-earth config, and connected ONLY my laptop.

Intrestingly enough, this allowed an upstream of 20Mbit, but back to 1-1.5Mbit downstream.

So I removed ALL the NAT config, and placed my laptop on a public IP, further minimizing the config, but this resulted in the same terrible downstream speed. (still got 20Mbit upstream though.)

I've got no idea whatsoever what's causing this problem.

Under no circumstance does the router show any load:

CPU utilization for five seconds: 0%/0%; one minute: 0%; five minutes: 0%


These numbers are maybe up to 2,3 percent when all the customers are attached.

I also have a spare I/O card, the midplane with the PCMCIA card, and console port. I've tried to change that as well, and another I/O card (the fa3/0) changed that as well, all with the same results. (none).

So what I'm thinking, either the software dosen't support the NPE-300 network prosessor engine, or I'm a f#?%up with

IOS commands. On one of the routers I get BAD CPU_ID during boot, but only one of them.


I've posted a simple config, and the output of SH VER as well.

Does anybody see some simple stupid mistake / error here?


Thanks for your time;=)



Router#sh run

Building configuration...


Current configuration : 1007 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

no aaa new-model

ip subnet-zero

!

no ip domain lookup

!

ip dhcp pool test1

network 10.0.0.0 255.255.255.0

default-router 10.0.0.1

domain-name h00rer.com

!

ip cef

!

interface FastEthernet0/0

ip address 80.xx.123.2 255.255.255.252

ip nat outside

duplex full

!

interface FastEthernet3/0

no ip address

duplex full

!

interface FastEthernet3/0.192

encapsulation dot1Q 192

ip address 10.0.0.1 255.255.255.0

ip nat inside

!

ip nat pool ADSL-NAT-POOL 80.xx.123.2 80.xx.123.2 netmask 255.255.255.252

ip nat inside source list 8 pool ADSL-NAT-POOL overload

ip classless

ip route 0.0.0.0 0.0.0.0 80.xx.123.1 name Default_Gw

no ip http server

access-list 8 permit 10.0.0.0 0.0.0.255

gatekeeper

shutdown

!

!

line con 0

stopbits 1

line aux 0

line vty 0 4

!

end


----

Due to 4000 letter limitations, I will post output of SH VER in a reply to this thread.

----


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
markraves Mon, 07/30/2007 - 15:44
User Badges:

--------------------------


----------------------------------

This is router1's SH VER:

----------------------------------

Router#sh ver

Cisco Internetwork Operating System Software

IOS (tm) 7200 Software (C7200-JS-M), Version 12.3(6a), RELEASE SOFTWARE (fc4)

Copyright (c) 1986-2004 by cisco Systems, Inc.

Compiled Fri 02-Apr-04 15:51 by kellythw

Image text-base: 0x60008AF4, data-base: 0x61FF2000


ROM: System Bootstrap, Version 12.2(1r) [dchih 1r], RELEASE SOFTWARE (fc1)


Router uptime is 31 minutes

System returned to ROM by reload at 00:08:35 CEST Tue Jul 31 2007

System image file is "disk0:c7200-js-mz.123-6a.bin"

Last reload reason: Reload command



cisco 7206VXR (NPE300) processor (revision D) with 229376K/65536K bytes of memor

y.

Processor board ID 25859418

R7000 CPU at 262MHz, Implementation 39, Rev 2.1, 256KB L2 Cache

6 slot VXR midplane, Version 2.5


Last reset from power-on

Bridging software.

X.25 software, Version 3.0.0.

SuperLAT software (copyright 1990 by Meridian Technology Corp).

TN3270 Emulation software.


PCI bus mb0_mb1 has 400 bandwidth points

PCI bus mb2 has 0 bandwidth points


2 FastEthernet/IEEE 802.3 interface(s)

125K bytes of non-volatile configuration memory.


125440K bytes of ATA PCMCIA card at slot 0 (Sector size 512 bytes).

4096K bytes of Flash internal SIMM (Sector size 256K).

Configuration register is 0x2102


Router#


------------------------------------

This is router 2's SH VER:

------------------------------------

Router#sh ver

Cisco Internetwork Operating System Software

IOS (tm) 7200 Software (C7200-JS-M), Version 12.3(6a), RELEASE SOFTWARE (fc4)

Copyright (c) 1986-2004 by cisco Systems, Inc.

Compiled Fri 02-Apr-04 15:51 by kellythw

Image text-base: 0x60008AF4, data-base: 0x61FF2000


ROM: System Bootstrap, Version 12.0(19990210:195103) [12.0XE 105], DEVELOPMENT S

OFTWARE


Router uptime is 3 minutes

System returned to ROM by power-on

System image file is "disk0:c7200-js-mz.123-6a.bin"


cisco 7206VXR (NPE300) processor (revision B) with 229376K/65536K bytes of memor

y.

Processor board ID 21274384

R7000 CPU at 262MHz, Implementation 39, Rev 1.0, 256KB L2 Cache

6 slot VXR midplane, Version 2.0


Last reset from power-on

Bridging software.

X.25 software, Version 3.0.0.

SuperLAT software (copyright 1990 by Meridian Technology Corp).

TN3270 Emulation software.


PCI bus mb0_mb1 has 400 bandwidth points

PCI bus mb2 has 0 bandwidth points


2 FastEthernet/IEEE 802.3 interface(s)

125K bytes of non-volatile configuration memory.


125440K bytes of ATA PCMCIA card at slot 0 (Sector size 512 bytes).

4096K bytes of Flash internal SIMM (Sector size 256K).

Configuration register is 0x100 (will be 0x0 at next reload)


Router#

markraves Mon, 07/30/2007 - 16:19
User Badges:

Sorry for all the pasting here, but I thought I'd post the SH DIAG as well here, to let you in on my expansion slots...


Router#sh diag

Slot 0:

Fast-ethernet on C7200 I/O card with MII or RJ45 Port adapter, 1 port

Port adapter is analyzed

Port adapter insertion time 00:57:00 ago

EEPROM contents at hardware discovery:

Hardware revision 2.1 Board revision B0

Serial number 16704758 Part number 73-4092-03

FRU Part Number: C7200-IO-FE-MII/RJ45=


Test history 0x0 RMA number 00-00-00

EEPROM format version 1

EEPROM contents (hex):

0x00: 01 83 02 01 00 FE E4 F6 49 0F FC 03 00 00 00 00

0x10: 58 00 00 00 00 05 24 00 00 00 FF FF FF FF FF FF


Slot 3:

Fast-ethernet (TX-ISL) Port adapter, 1 port

Port adapter is analyzed

Port adapter insertion time 00:57:00 ago

EEPROM contents at hardware discovery:

Hardware revision 1.4 Board revision B0

Serial number 21920029 Part number 73-1688-05

FRU Part Number: PA-FE-TX


Test history 0x0 RMA number 00-00-00

EEPROM format version 1

EEPROM contents (hex):

0x00: 01 11 01 04 01 4E 79 1D 49 06 98 05 00 00 00 00

0x10: 58 00 00 00 00 09 02 00 FF FF FF FF FF FF FF FF

purohit_810 Mon, 07/30/2007 - 19:19
User Badges:
  • Silver, 250 points or more

I can suggest Only one thing to you....


At the time of working Environment mean when problem persist at that time, Please capture some traffic by using sniffer. and analyze.


That is only can help to resolve Throughput problem.


Regards,

Dharmesh Purohit

paolo bevilacqua Mon, 07/30/2007 - 23:05
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

No eveident mistakes. Do you have acess to downloads ? Can you upgrade to latest 12.3 ? (line (40) or so.

markraves Tue, 07/31/2007 - 03:26
User Badges:

Hello,

No, I don't have access to downloads.


This is indeed very strange. Later yesterday night, I took the spare FA card and inserted it in slot 2/0.

Then I connected the wan interface in slot 2/0 instead of 0/0.

When I had a speed test (with my full configuration) I got 1/20Mbit from nat'ed net, and I got 4/5Mbit from a net without nat. I did this about five times, and no variations to speak about.


I'm utterly clueless.


Purohit: Well, the problem kinda persists ALL the time, so it shouldn't be hard finding the time. I will try some sniffing.


Thanks;=)

Actions

This Discussion