Upgrade path for IPCC 4.0 to 5.0?

Unanswered Question
Jul 31st, 2007
User Badges:

Hi,


Can anyone tell me if there is an upgrade path from IPCC Express 4.0 to 5.0?


I understood it to be


4.0 - 4.5(1)SR1. Then 4.5SR1 to 5.0?


Thanks in advance!

Tim Moffett

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
lpezj Tue, 07/31/2007 - 05:14
User Badges:
  • Gold, 750 points or more

Hi,


I think that you don't need to upgrade to version 4.5. You can upgrade to version 5 from version 4.


Keep in mind that ypu need to upgrade first your CallManager to version 6, prior to aupgrade IPCC Express to version 5.


IPCC Express 4.5 works only with CallManager 5.


Hope this helps,


Juan Luis

Chris Deren Tue, 07/31/2007 - 08:29
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

IPCCX 5.1 works with CM 5.X as well.


http://www.cisco.com/univercd/cc/td/doc/product/voice/sw_ap_to/crscomtx.pdf


You can not upgrade directly from 4.0 to 5.0, the only supported upgrade is from 4.5.

There is no upgrade path from 4.0 to 5.0 as you have to rebuild the server.

So, to upgrade IPCCX 4.0 to 5.0 you have to rebuild the server as well. Keep in mind that IPCCX 5.0 requires windows 2003 server as well.


HTH, please rate all helpful posts!


Chris

Chris Deren Tue, 07/31/2007 - 08:30
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

I ment to say IPCCX 5.0 works with CM 5.1.


Chris

tmoffett Tue, 07/31/2007 - 13:45
User Badges:

So, the million dollar question is: Is there a data migration option, or is this a complete rebuild and application development effort?


Thanks!

Tim


Chris Deren Tue, 07/31/2007 - 14:49
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

Complete rebuild :-(


Chris

tmoffett Fri, 08/03/2007 - 09:41
User Badges:

Thanks everyone for the replies...


Can anyone comment on the compatibility of the actual scripts?


Thanks in advance!


Tim

Chris Deren Fri, 08/03/2007 - 11:39
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

The scripts should work just fine, as the script editor has not been changed at all.


Chris

akaradetch.n Thu, 06/26/2008 - 23:46
User Badges:

What is the best solution to migrate data to new 5.0?


Can I use BARS to backup (from 4.0) and restore (on 5.0)?


Waiting for your help, thank you in advance.

Chris Deren Fri, 06/27/2008 - 06:43
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

There is no migration from 4.0 to 5.0, you will need to do the following:

manually backup all of your scripts, docuemnts, grammar, prompts, etc

take screenshots of all subsystems configurations

take screenshots of all CAD configurations

Rebuild the server with Cisco provided windows 2003 server

install UCCX 5.0

import all files, rebuild all configuration


Sorry, this is the only way :-(


Chris

goranpilat Thu, 07/03/2008 - 13:20
User Badges:

Hi Chris!


I am also preforming 4.0(5) express premium->5.0 upgrade. It will be running with CCM 6.1. What I find confusing is ordering this upgrade. Those CCX-UPG part numbers cost 0$ on configurator tool, is that right? Is CCX-UPG-P-40-50= ok in your opinion? Why don't I have win2003 included in this part number like it is included in CCX-UPG-P-40-60=??? Is there need to order anything else if the hardware is ok?


Please, I need any piece of advice.


Best regards,


Goran

Chris Deren Fri, 07/04/2008 - 05:01
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

If you are covered with SmartNet software subscription the upgrade is always free. If you dont have a valid subscription then I belive you have to buy the complete product. Instead of going thru configuratoin tool I would recommand going through PUT assuming you have valid smartNet on the product, Cisco will send you the UCCX media along with windows 2003 media this way for sure.


HTH,


Chris

Jeff Garner Mon, 07/07/2008 - 05:54
User Badges:

Has any one done the upgrade from via the PUT tool? I was able to complete the install however the license file generated from the PAK / Serial would not take...

The software would also not take my 4.x license...

antonio.vazquez Thu, 07/03/2008 - 23:17
User Badges:
  • Bronze, 100 points or more

Why don't you migrate to new 6.x (CCM 4.3)?

There is a direct path to do this migrate indeed of doing a migration to 5.x.


Regards,

akaradetch.n Mon, 07/07/2008 - 01:55
User Badges:

Actually we are upgrading from CCM4.2 to CUCM6.1 (latest), that means we have to upgrade to IPCC 5.0 because CUCM6.1 doesn't support for IPCC 6.0 (from compatibility matrix).


Any recommend for this case?

Actions

This Discussion