More Vlan Questions

Unanswered Question
Jul 31st, 2007

I'm in the process of setting up vlan on our 3750 Cisco switches I need 14 vlans our network addresses starts with 10.10.0.0/22 (10.10.4.0/22, 10.10.8.0/22, 10.10.12.0/22?)

When I configure the vlan using rip as shown below everything works correctly I get handed a DHCP address, I can browse the internet it all works.

-----------------------------------------------

!

interface Vlan305

ip address 10.10.12.1 255.255.0.0

ip helper-address 10.4.48.1

ip helper-address 10.4.55.18

!

router rip

network 10.0.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.4.9.1

ip http server

!

---------------------------------------------

The problem is I need to have it set up like this with a Netmask of 255.255.252.0 but when I do nothing works, no DHCP no internet, no login?

-----------------------------------------------

!

interface Vlan305

ip address 10.10.12.1 255.255.252.0

ip helper-address 10.4.48.1

ip helper-address 10.4.55.18

!

router rip

version 2

network 10.0.0.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.4.9.1

ip http server

!

---------------------------------------------


Our whole network is dumped into vlan 1 right now.

10.4.48.1 is the Novell DNS/DHCP server.

10.4.55.18 is the Novell Zenworks Imaging server.

10.4.9.1 is the gateway on the Juniper ISG-1000.

DHCP is set up for just about everything in the 10.4.0.0 range


I have two switches set up right now

10.4.10.10 and 10.4.10.12 they are connected by Cat5

10.4.10.10 port gi1/0/32 is connected to 10.4.10.12 Port gi1/0/39

I have 1 workstation set up into Vlan 305 it?s on switch 10.4.10.12 port gi1/0/21


I need this one workstation in vlan 305 to be able to access the internet (10.4.9.1) as well as communicate with the Novell servers (10.4.55.18)


I've attached the config sheets for both switches as well as "sh vlan" for both switches...




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Amit Singh Tue, 07/31/2007 - 05:31

Please attach a brief network topology. This would make understanding the internet connectivity to the network.


Also paste " show ip route " from the switch 10-10


-amit singh

albolabris Tue, 07/31/2007 - 05:45

Switch 10.4.10.10 has everything plugged in to it Servers and the Juniper box everything resides in Vlan1 right now. The Juniper box has the IP address of 10.4.9.1 that is the gateway to the internet.

Switch 10.4.10.12 is on the other side of the room and has my workstations connected into it.

Eventually I will push the vlans out to the entire network but for now I'm just trying to get it working between these 2 switches


-Scott




Attachment: 

Actions

This Discussion