diff vlans from cisco4506

Answered Question
Jul 31st, 2007
User Badges:

Hi Experts,

I am trying to figure out something on the Cisco4506 inter-vlan routing.. As understand, If we configured, Interface vlan 3 for 10.30.3.0 / 24 and interface vlan 4 for 10.30.4.0 / 24, PC of 10.30.3.4 will be able to ping to 10.30.4.4 PC connected to 10.30.4.0 network. Is this statement valid? Assumption here is there is no access-lists applied on the interface vlan.


thanks in advanced,


Correct Answer by Edison Ortiz about 9 years 9 months ago

One more thing, do you have multiple routers sharing the Vlan hence the need for HSRP ?


Can we also see the same from the other device


show ip route


and


show stand


Correct Answer by ankbhasi about 9 years 9 months ago

Hey Cindy,


Yes you have to enable "ip routing" to make communication work between vlan. "Ip routing" is by default enabled on IOS releases.


But incase if you have disabled it you can enable going to configu mode.


Switch(config)#ip routing


Try that and see if it helps!!


Regards,


Ankur

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (3 ratings)
Loading.
Edison Ortiz Tue, 07/31/2007 - 07:24
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

As long as both segments point to the switch as the default gateway, Yes.

ankbhasi Tue, 07/31/2007 - 07:35
User Badges:
  • Cisco Employee,

Hi Friend,


In addition to Edison post assuming "ip routing" is enabled then YES you are right.


Regards,


Ankur

cindylee27 Tue, 07/31/2007 - 08:18
User Badges:

Hi Guys,

Thanks for your advise.. For eg, i have the config as below.. I would like to have the Users from Vlan13 to talk to Vlan14..with the IP Routing, what is the default gateway that I should set so that both of them can talk to each other???


Thanks in advanced again..


----------------------------------------

interface Vlan13

ip address 10.1.13.200 255.255.255.0

ip helper-address 10.1.18.120

no ip redirects

no ip proxy-arp

ntp disable

standby 13 ip 10.1.13.254

standby 13 priority 110

standby 13 preempt

!

interface Vlan14

ip address 10.1.14.200 255.255.255.0

no ip redirects

no ip proxy-arp

ntp disable

standby 14 ip 10.1.14.254

standby 14 priority 110

standby 14 preempt


----------------------------



glen.grant Tue, 07/31/2007 - 08:22
User Badges:
  • Purple, 4500 points or more

All client pc's in vlan 13 have to be pointed to 10.1.13.254 and all client pc's int vlan 14 have to be pointed to 10.1.14.254 .

ankbhasi Tue, 07/31/2007 - 08:23
User Badges:
  • Cisco Employee,

Hi Cindy,


In your case you have configured HSRP on your vlan interfaces so for machines in vlan 13 you should configure gateway address as 10.1.13.254 and for machines in vlan 14 gateway address will be 10.1.14.254.


Had it been the case where you have not configured HSRP then vlan 13 machines should have gateway configured as 10.1.13.200 and machines in vlan 14 should have gateway address as 10.1.14.200.


HTH


Ankur


*Pls rate all helpfull post

cindylee27 Tue, 07/31/2007 - 08:28
User Badges:

Yup, Ankur.. I will rate those helpful post..

but one funny thing is..


I can';t ping the PC from vlan13 to vlan14..is the command applied at the interface prevent it from tracert or ping?? btw, this config is not IP Routing enabled. Will this cause it as well?


thanks..


Edison Ortiz Tue, 07/31/2007 - 08:31
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Please post the output from typing


show ip route


and


show stand

cindylee27 Tue, 07/31/2007 - 08:41
User Badges:

Hi Edison,

I am currently at home now..:) will post to you all when back to office tomorrow..


Thanks guys..and will keep you all updated.


Ankur, my config didn;t have Ip routing statement,is that mean tat it is disable or not shown? How can i go about checking if ip routing is enable? by showing "show ip route"?


Thanks,


Correct Answer
Edison Ortiz Tue, 07/31/2007 - 10:01
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

One more thing, do you have multiple routers sharing the Vlan hence the need for HSRP ?


Can we also see the same from the other device


show ip route


and


show stand


Correct Answer
ankbhasi Tue, 07/31/2007 - 08:37
User Badges:
  • Cisco Employee,

Hey Cindy,


Yes you have to enable "ip routing" to make communication work between vlan. "Ip routing" is by default enabled on IOS releases.


But incase if you have disabled it you can enable going to configu mode.


Switch(config)#ip routing


Try that and see if it helps!!


Regards,


Ankur

cindylee27 Tue, 07/31/2007 - 19:03
User Badges:

Thanks Guys!

Managed to sort it out..they are indeed able to ping each other..There is a firewall utility which block the pinging..disable it, it works..


But, Ankur.. just one question..you were saying by default,it is IP Routing enable..how can I check that if it is not showing on the config sh run file??

I have rated you guys post ya..:)

thanks again..


mahmoodmkl Tue, 07/31/2007 - 20:43
User Badges:
  • Gold, 750 points or more

Hi


what Ankur meant was the ip routing is enabled by default in the current IOS releases.It will not show up in u r running config.I think u can type no ip routing and check,if it shows up in the running-config then it means that it was enabled.


Thanks

Mahmood

Edison Ortiz Wed, 08/01/2007 - 05:42
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

You can verify if routing is enabled by typing


show ip route


With IP routing enabled, you get something like this:


Rack1SW2#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route



Without ip routing enable, you get something like this:


Rack1SW2#show ip route

Default gateway is not set


Host Gateway Last Use Total Uses Interface

ICMP redirect cache is empty




Actions

This Discussion