vrf lite

Unanswered Question
Jul 31st, 2007


I want to use vrf lite with ipip tunnel but unfortunately it works one way but not the other.

here is my config:

ip vrf uk

rd 69:129

interface Tunnel2

description IPIP tunnel to UK

ip vrf forwarding uk

ip unnumbered Vlan2

tunnel source Dialer0

tunnel destination <public_tunnel_router_ip>

tunnel mode ipip

tunnel path-mtu-discovery

tunnel vrf uk

ip route Dialer0

ip route vrf uk Tunnel2

interface Vlan2

ip dhcp relay information trusted

ip vrf forwarding uk

ip address

ip helper-address global

i can ping throught the tunnel from but i can t ping from the router to throught the tunnel (ping source vlan2)

the odd thing is that it is working one way and not an other...

I can t see any problem with my onfig.

sh ip vrf interfaces

Interface IP-Address VRF Protocol

Vl2 uk up

Tu2 uk up

everything is up but the counter from int tunnel 2 doesn t increase meaning the traffic doesn t go in the tunnel.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)

VRF-lite is a feature that enables a service provider to support two or more VPNs, where IP addresses can be overlapped among the VPNs. VRF-lite uses input interfaces to distinguish routes for different VPNs and forms virtual packet-forwarding tables by associating one or more Layer 3 interfaces with each VRF. Interfaces in a VRF can be either physical, such as Ethernet ports, or logical, such as VLAN SVIs, but a Layer 3 interface cannot belong to more than one VRF at any time



This Discussion