outbound calls not working

Unanswered Question
Jul 31st, 2007

my internal calls (IP) are working fine, and we can receive external calls, and outbound long distnace 1(xxx)calls are all working fine, but "local" outbound calling are not working. I have used the basic 9T and .T destination-pattern but they both give a busy signal after the timeout.

Any ideas? Is my telco expecting more than 7 digits for local calls?

voice-port 0/0/0:23

local-alerting

timeouts interdigit 5

dial-peer voice 10 pots

destination-pattern .T

no digit-strip

direct-inward-dial

port 0/0/0:23

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
v-yelmene Tue, 07/31/2007 - 10:53

The PBX switch is a dms100 type. All inbound calls seem to work fine. There was no output from "debug isdn q931".

voice-port 0/0/0:23

local-alerting

timeouts interdigit 3

dial-peer voice 10 pots

destination-pattern .T

no digit-strip

direct-inward-dial

port 0/0/0:23

forward-digits all

Paolo Bevilacqua Tue, 07/31/2007 - 11:02

Hi,

please do "term mon" before debug command. If still no output, please check that "show logging" says that "monitor logging" is enabled. If still no output,please enable "debug dialpeer".

Chris Deren Tue, 07/31/2007 - 11:02

Are you using callManager?

Make sure your calling search space/parition/GW/Route patterns are configured properly.

Can you post your entire router config?

Chris

Chris Deren Tue, 07/31/2007 - 11:07

Can you post your entire config as well as type these commands in and make a call:

term mon

debug isdn q931

debug voice dialpeer

Chris

v-yelmene Tue, 07/31/2007 - 11:10

msc-CME#

Jul 31 11:09:50.767: ISDN Se0/0/0:23 Q931: Applying typeplan for sw-type 0x5 is 0x2 0x1, Calling num 3400

Jul 31 11:09:50.767: ISDN Se0/0/0:23 Q931: Applying typeplan for sw-type 0x5 is 0x2 0x1, Called num 3736149

Jul 31 11:09:50.767: ISDN Se0/0/0:23 Q931: TX -> SETUP pd = 8 callref = 0x008F

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98397

Exclusive, Channel 23

Progress Ind i = 0x8183 - Origination address is non-ISDN

Display i = 0xB1, 'Vince Yelemenl'

Calling Party Number i = 0x2180, '3400'

Plan:ISDN, Type:National

Called Party Number i = 0xA1, '3736149'

Plan:ISDN, Type:National

Jul 31 11:09:50.795: ISDN Se0/0/0:23 Q931: RX <- STATUS pd = 8 callref = 0x808F

Cause i = 0x80E328 - Information element not implemented

Call State i = 0x01

Jul 31 11:09:50.831: ISDN Se0/0/0:23 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x808F

Cause i = 0x809C - Invalid number format (incomplete number)

Chris Deren Tue, 07/31/2007 - 11:12

Cause i = 0x809C - Invalid number format (incomplete number)

Telco may be expecting more digits, what area code are in in?

Chris

v-yelmene Tue, 07/31/2007 - 11:14

I am in Alaska (907), trying to call a local number 373-xxxx, If I dial a long distance call, 1(907)xxx.xxxx it works fine. I guess I need to ask the telco what they are expecting for local calls.

v-yelmene Tue, 07/31/2007 - 11:22

thanks, I suspected it was a telco issue.

It's always the telco. At least up here it is. I just wanted to make certain.

vmilanov Tue, 07/31/2007 - 11:44

Hi again,

just saw that you have managed with the debug output while I was writing my post.

Take a look at my other post. Pay attention on having separate dial-peers for the different types of outgoing calls.

I see that your number type is 'National', so you might have either to re-write it as 'Unknown'(not sure if this should help, telco pending), or to prefix it with the local area code so it will extend to the national number format.

I'm using voice trnaslation profiles/voice translation-rules, applied to the relevant dial-peers as nedded.

regards

v-yelmene Tue, 07/31/2007 - 11:49

if I dial using the area code (907)373-6129, I get message from Telco PBX, "do not need to dial area code....". If I add prefix 907, I get same Telco message,

vmilanov Tue, 07/31/2007 - 12:03

Then try to re-write the called number type in your setup message.

Also, consider issuing the 'isdn sending-complete' command under the interface Serial 0/0/0:23 configuration. Never the less you are sending the number enblock, not digit-by-digit, the telco migh expect the 'sending complete' message from your side.

Anyway, it's better to open a ticket there.

Regards.

vmilanov Tue, 07/31/2007 - 11:30

You should have an output, try issuing 'terminal monitor' right before/after the 'debug isdn q931' command. That is a mandatory step to see the debug output on your screen if you are accessing the router via a telnet or a ssh session (you are connected to a vty line in this case).

The console port is in monitoring state by default.

Once you get the debug output you can go further.

Just to mention, that I personaly consider as a good practice to split the dial-peers for the incoming and the outgoing call into separate records, or even further you can have spare dial-peers for the intrnational, long distance, and local calls. This would make the configuration more clear and flexible. If you do so, then you cam manipulate the ANI, DNIS, numbering plan, etc. on a per-call-type basis.

HTH.

Regards,

Vasil

Actions

This Discussion