Simple VLAN question

Unanswered Question
Jul 31st, 2007
User Badges:

Hello,


I am trying something not sure if it can work or not. Here it is simply put.


I have a Cisco 3550 running an EMI image. It has a cross connect to a 2950T cisco switch. I am trying to put through VLAN 3 and 63 from the 3550 to the 2950, I usually do that using 802.1Q Trunk, but the specific port in the 2950 was set to STATIC access meaning it responds to ONE vlan. Now I want the 2950 port (meaning the server directly) seeing BOTH vlan 3 and 63, what settings do I need to put in the 3550 and 2950 so that the port on which the server is attached to will communicate on BOTH vlan at the same time??


Help is greatly appreciated


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Tue, 07/31/2007 - 12:24
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Hi


If you want your server to be able to send and receive traffic for both vlans you need to make the port a trunk port and run 802.1q on your server NIC if it is supported.


HTH


Jon

existhosting Tue, 07/31/2007 - 12:58
User Badges:

This is for dedicated server customers, we cannot edit the NIC details or configs. We need a solution at the switches level... anything we can do?


Thanks

Edison Ortiz Tue, 07/31/2007 - 14:32
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

The 3550 is a multi-layer switch so it can route between these 2 Vlans and the server can reside in one of the 2 Vlans but still able to communicate to the other Vlan via the 3550 Layer3 switched process.


What's the server current default gateway ?

existhosting Tue, 07/31/2007 - 15:41
User Badges:

thanks for helping... yes it is a multilayer so basically I have two gateways.


The current server default gateway is


XX.XX.60.1 - VLAN 3


The other gateway setup for this server is a 2555.248 subnet and the gateway is XX.XX.97.241 - VLAN 63


The current setup is for VLAN3, what steps EXACTLY (as I am not too technical) must I make in order for the server to talk to BOTH VLANS ??


Thank You

Edison Ortiz Wed, 08/01/2007 - 05:47
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

If the server's gateway is pointing to x.x.60.1, I'm assuming this is the IP address under interface Vlan3 at the switch ? If so, you don't need to do anything. The switch will route packets between Vlan3 and Vlan63.

existhosting Wed, 08/01/2007 - 07:16
User Badges:

Yes it is pointing to that gateway on the server...


But I tried that but the 2950 port for that server is configured to be Vlan3 static access so it does not see the Vlan63 at all I think. I am not sure what to do. I did not make any intervlan routing for now and I am not sure what settings to put in the 3550 and in the 2950... can you detail me exactly what settings need to be put and where??


PS: As well, does the new vlan63 gateway need to be put inside my server's nic configuration as an available gateway..but I think I can only set one gateway per nic card??


Please let me know


Thanks

Jon Marshall Wed, 08/01/2007 - 07:20
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Hi


No you don't need to add the vlan 63 gateway to your server NIC. If both vlan 3 and vlan 63 have Layer 3 interfaces on the 3550 then you just need to enable ip routing on the 3550 and you should be able to communicate between the vlans eg


3550_switch(config t)# ip routing


HTH


Jon

Edison Ortiz Wed, 08/01/2007 - 07:22
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

The 2950 port configuration should be fine as Vlan3. Can you describe what exactly you mean as 'can not see Vlan63' ?


Are you trying to ping devices from the server in Vlan3 to devices in Vlan63 ?


or


Are you browsing network neighborhood ?


Browsing network neighborhood relies on Windows peer-to-peer networking (WINS or DNS) and that needs to be addressed later. I will help you on the L3 connectivity between Vlans and the test we are going to do is with ping.


In order for the 2 Vlans to route between each other, you need to enable inter-vlan routing in the 3550 by typing the command 'ip routing'.


Can you post config from the 2950 and 3550 switch ?


existhosting Wed, 08/01/2007 - 08:15
User Badges:

Hello,


Doesn't IP Routing enables as it says it IP routing?? of course it is enabled as we route all our network on it. But for example on an exterior network I cannot ping the IP attached to the server on VLAN 63 unless i change the static port on the 2950 to vlan 63 but then the IP on vlan 3 doesn't ping anymore...


I know maybe Inter-Vlan routing is not enabled perhaps... but isnt the command IP ROUTING just to enable IP routing.. which is already enabled...


Thanks

Edison Ortiz Thu, 08/02/2007 - 06:56
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

If you have 'ip routing' configured in the 3550, then you have inter-vlan routing working. However, devices on each Vlan must have their default gateway pointing to the 3550 Vlan interface.


For instance on the 3550, you should have


interface Vlan 3

ip add x.x.3.1 255.255.255.0


interface Vlan 63

ip add x.x.63.1 255.255.255.0


And the devices on Vlan 3, must have default gateway, x.x.3.1 while devices on Vlan 63 must have default gateway x.x.63.1


existhosting Thu, 08/02/2007 - 08:28
User Badges:

Hello,


can you use my end of IP's I posted as I am not sure what you are saying I must do in my switch configuration...


Can you please use my IP settings I posted with corresponding vlans so you can tell me exactly what I need to do?


Here are my two vlans configuration in th switch:


interface Vlan3

ip address XX.XX.60.1 255.255.255.0


interface Vlan63

ip address XX.XX.97.241 255.255.255.248


perhaps you can tell me exactly what needs to be done now that you have my configurations...


Thank You

existhosting Thu, 08/02/2007 - 12:19
User Badges:

In addition to the post above, the problem seems to be because in the 2950 switch the port is set to static access on VLAN 3, that is why it can only talk to ONE VLAN, the intervlan routing is done, I know that. The problem is on that level and I cannot seem to allow a port on the 2950 to talk to TWO vlans at the same time... how can this be accomplished?


Thanks

Edison Ortiz Thu, 08/02/2007 - 12:30
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Elazar,


Can you define what you mean when you say


"talk to TWO vlans at the same time" ?


The server will be able to communicate to all Vlans at the same time by using the 3550 switch as the gateway to the rest of the network.


If you want the server to have multiple IPs and be able to communicate to both Vlans without the need for the 3550 as a routing device, you must configure trunking in the 2950 port where the server is connected and the server NIC must support trunking as well.


You need to understand trunking configuration at the switch and server level. I will help you with the switch but I won't help you with the server.


For your network setup, I don't see the need to do that. The server will be able to communicate effectively with all Vlans by using the 3550 switch.


To answer your other inquiry, workstation/servers on Vlan3 must have XX.XX.60.1 as their default gateway while workstations/servers on Vlan63 must have XX.XX.97.241 as their default gateway.


HTH,


existhosting Thu, 08/02/2007 - 13:00
User Badges:

Hello,


This is what we are trying to do. For example server 63 in our inventory is currently on VLAN 3... we need to migrate it on its OWN vlan which is Vlan 63 which sits on completely different IP's therefore two different gateways. We need to give our customer a 2 week period in which he will have BOTH sets of IP's on the server so he can have a smooth migration...


Hope this is clearer.. We cannot play with the server's NIC card, we need to do this at the switch/router level.


The problem is that we do not know which configuration should be put on the 2950T since now it is set to STATIC access on VLAN3, therefore the IP's on vlan 63 CANNOT get through whether the 3550 routes between them or not, they get to the 2950T fine, but the port itself is set to vlan 3... so WHAT must be set??


Hope this is clear


Thanks

Edison Ortiz Thu, 08/02/2007 - 16:07
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

If the server currently has an IP that belongs in Vlan63, then change the Vlan membership in the 2950 to Vlan63.


The server can't be in both Vlans at the same time unless you configure trunking at the switchport and the server NIC.


Hope that's clear enough.

existhosting Thu, 08/02/2007 - 16:13
User Badges:

yes but if I change it to Vlan 63 then the customer will lose the IP connectivity he had from VLAN 3 ...


What is (apart from the server's nic config) the way for that server to talk to BOTH VLAN3 and VLAN63 at the SAME time so he can migrate smoothly ?


Thank You

Edison Ortiz Fri, 08/03/2007 - 05:55
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Can you explain the current server's NIC config ?


An IPCONFIG /ALL will be helpful.

existhosting Fri, 08/03/2007 - 06:47
User Badges:

Hello,


yes I can post that, the only thing is that those are Dedicated Server Customers and we do not have access to all the servers or want to manually configure over 300 servers and not all NIC will be the same, therefore we cannot rely on that solution.


We need a router/switch level solution, ANY solution, that will let us have both VLAN 3 and VLAN 63 IP's available for that server...


Anything that can be done with the 3550 and 2950 switches ???


Thanks

pwd88cisco Thu, 10/18/2007 - 05:07
User Badges:

Please make sure the link between 2950 switch and 3550 switch is configured as trunk, look for something like these:

switchport encapsulation dot1q

switchport mode trunk

switchport trunk allow vlan 3,63

so that both vlans can traverse through to 3550 for the inter-vlan routing, on your 2950 access port which connects to the server, I am assuming it is currently configured something like this:

switchport mode access

switchport access vlan 3

and the server is configured with an IP address in vlan 3 subnet (for instance: x.x.60.3), when you are ready to move the server from vlan 3 to vlan 63, what you need to do is to make a configuration change on 2950 port which the server connects to:

switchport access vlan 63

then change the server NIC IP address to be one of IP address in vlan 63 subnet, as well as the default gateway

Actions

This Discussion