EIGRP and BGP mutual redistribution.

Unanswered Question
Aug 1st, 2007

I am doing mutual redistribution with the following:

router eigrp 10

redistribute bgp 64586 metric 155000 10 255 1 4470 route-map bgp-to-eigrp



! redist bgp routes with route-map and metric

router bgp 64586

no synchronization

bgp log-neighbor-changes

redistribute eigrp 10 route-map eigrp-to-bgp

neighbor remote-as 209

neighbor ebgp-multihop 2

neighbor update-source Loopback0

neighbor weight 40000

no auto-summary

!redist eigrp routes with route-map

access-list 1 permit

! rtdallas-7206

access-list 2 permit

! rtapple

access-list 3 permit

! rtlb

access-list 4 permit

! rtbrun

access-list 5 permit

! rteb

access-list 6 permit

! rtdal-fg

access-list 7 permit

! rtwest

access-list 8 permit

! rt6513-nw

access-list 9 permit

! rt6513-d

access-list 10 permit

! rt6513-3

access-list 11 permit

! rtgac4

access-list 12 permit

! rtgac-old

route-map eigrp-to-bgp deny 10

match ip next-hop 1


route-map eigrp-to-bgp deny 11

match ip next-hop 2


route-map eigrp-to-bgp deny 12

match ip next-hop 3


route-map eigrp-to-bgp deny 13

match ip next-hop 4


route-map eigrp-to-bgp deny 14

match ip next-hop 5


route-map eigrp-to-bgp deny 15

match ip next-hop 6


route-map eigrp-to-bgp deny 16

match ip next-hop 7


route-map eigrp-to-bgp deny 17

match ip next-hop 8


route-map eigrp-to-bgp deny 18

match ip next-hop 9


route-map eigrp-to-bgp permit 30

set tag 10

!set tag to deny later in redist to bgp

route-map bgp-to-eigrp deny 10

match tag 10

!deny routes learned from eigrp


route-map bgp-to-eigrp permit 20

set tag 64586

set ip next-hop

This seems to work except for routes in EIGRP at another router.

rt6513-3 is running both protocols and doing the redistribution. It also has

the external BGP session. On this router the EIGRP entry for the BGP

learned route is

P, 1 successors, FD is 18944, tag is 64586

via Redistributed

and the route table entry is

6513-3#sh ip ro

Routing entry for

Known via "bgp 64586", distance 20, metric 0

Tag 209, type external

Redistributing via eigrp 10

Advertised by eigrp 10 metric 155000 10 255 1 4470 route-map bgp-to-eigrp

bgp 64586 (self originated)

Last update from 01:20:42 ago

Routing Descriptor Blocks:

*, from, 01:20:42 ago

Route metric is 0, traffic share count is 1

AS Hops 2

Route tag 209

When I go to another router that is running EIGRP only (rt6513-2n) the EIGRP

topo entry is

P, 1 successors, FD is 864000

via, Vlan92

via, Vlan92

The metric is now the same as the metric for the other route that is learned

natively in EIGRP from a 3rd router (rtgac).

I changed the delay on rtgac to try to force the BGP learned route to have a

higher metric, but what happened is both routes have the new higher metric in


before the change they both showed 858880.

The metrics for these should be calculated from these values

rtgac rt6513-3

155000 44210

10 20

255 255

1 5

4470 1500

If I shut down the interface for the route on rtgac I get this on (6513-2n)

P, 1 successors, FD is 19200, tag is 64586

via, Vlan92

If I no shut the interface it goes back to this

P, 1 successors, FD is 864000

via, Vlan92

via, Vlan92

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Pavel Bykov Fri, 08/03/2007 - 05:43

Please post the topology. I don't quite understand where the other router connects to.

You have posted the configuration from one router only. Is the configuration same on the other routers?

I cannot help you exactly without topology and all of the configuration, but try redistributing without route-maps, and then gradually add route-map complexity.

This config seems ok, if you're really blocking all the next hops you need to block, and not the ones you don't want.


This Discussion