no spanning-tree optimize bpdu transmission

Answered Question
Aug 2nd, 2007

What is "spanning-tree optimize bpdu transmission". I have this in a bunch of my switches and haven't found a good reference for it. TIA.

-John

I have this problem too.
0 votes
Correct Answer by Edison Ortiz about 9 years 4 months ago

The cool feature is that it optimizes bpdu transmission as the name states. However, when enabled it causes high CPU utilization since it runs in software, not hardware.

Cisco decided to disable this feature and hide it from the config. I guess some releases did not hide the command hence a bug was entered against it.

Correct Answer by Edison Ortiz about 9 years 4 months ago

Check Bug CSCee70806 at

http://www.cisco.com/cgi-bin/Support/Bugtool/launch_bugtool.pl

____________________

Release Notes

"no spanning-tree optimize bpdu transmission" cannot be removed from the "show running" output.

No workaround available

_________________________

Fixed-in Version: 12.2(25)SE

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Edison Ortiz Thu, 08/02/2007 - 07:20

Basically, this command shouldn't be seen in the config and the 'no' option should be removed. It's a bug in the IOS, what platform are you running ?

jmistich Thu, 08/02/2007 - 07:30

I have it on 3750s and 2955s. I am running 12.2(various).

jmistich Thu, 08/02/2007 - 08:05

I thought there might have been a cool feature I wasn't aware of. Oh well. Thanks.

Correct Answer
Edison Ortiz Thu, 08/02/2007 - 08:08

The cool feature is that it optimizes bpdu transmission as the name states. However, when enabled it causes high CPU utilization since it runs in software, not hardware.

Cisco decided to disable this feature and hide it from the config. I guess some releases did not hide the command hence a bug was entered against it.

Darren Ramsey Thu, 01/03/2008 - 07:03

Edison,

Can you elaborate more on this? In older versions of 3750 code "no spanning-tree optimize bpdu transmission" showed up in the config and could not be changed. With new versions 12.2(25)SEE3 and 12.2(35)SE5, if you do a "write erase" and reload, the command is missing from the config meaning it's entered and on by default. Now where I'm confused is if I do a "default spanning-tree optimize bpdu transmission", the command shows up as no spanning-tree optimize bpdu transmission, like the older code.

So moving forward should it be "spanning-tree optimize bpdu transmission" or "no spanning-tree optimize bpdu transmission"? From your previous post you indicated it could cause high CPU utilization, so it should be turned off with "no spanning-tree optimize bpdu transmission"? I'm I understanding this correctly?

Edison Ortiz Sat, 01/12/2008 - 12:30

You are correct and the command should be hidden in the config as its the default value is "no spanning-tree optimize bpdu transmission".

The fact the command can be seen, it's a cosmetic bug.

HTH,

__

Edison.

Actions

This Discussion