HSRP problem

Unanswered Question
Aug 2nd, 2007
User Badges:

I am attempting to set up HSRP between two 2600 series routers, and am having an issue. One of the routers does not leave the Init stage. From the debugs it appears that the router 1 (the one I want to be the active router) is not participating in HSRP for some reason?

Here are the configs and debug info.


Router 1:

interface Ethernet0/0

description HSRP primary LAN connection

ip address 158.48.96.42 255.255.240.0

no ip redirects

no ip directed-broadcast

standby 10 priority 110

standby 10 preempt

standby 10 ip 158.48.96.44

standby 10 track Serial0/1.127 15


Debug from R1


Aug 2 10:19:38.941 UTC: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up

Aug 2 10:19:38.949 UTC: %STANDBY-6-STATECHANGE: Standby: 10: Ethernet0/0 state Init -> Init



Router 2:

interface Ethernet0/0

description HSRP backup LAN connection

ip address 10.48.96.43 255.255.240.0

no ip redirects

full-duplex

standby 10 priority 100

standby 10 ip 10.48.96.44



From router 1:

sh standby

Ethernet0/0 - Group 10

Local state is Init, priority 110, may preempt

Hellotime 0 holdtime 0

Hot standby IP address is 10.48.96.44 configured

Active router is unknown expired

Standby router is unknown expired

Standby virtual mac address is 0000.0c07.ac0a

Tracking interface states for 1 interface, 1 up:

Up Serial0/1.127 Priority decrement: 15


From router 2:

sh standby

Ethernet0/0 - Group 10

Local state is Active, priority 100

Hellotime 3 holdtime 10

Next hello sent in 00:00:02.010

Hot standby IP address is 10.48.96.44 configured

Active router is local

Standby router is unknown expired

Standby virtual mac address is 0000.0c07.ac0a

8 state changes, last state change 00:04:28


Debugs from r2:


Aug 2 14:14:21.549 UTC: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up

Aug 2 14:14:22.551 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to up

Aug 2 14:14:22.559 UTC: SB: Ethernet0/0 Interface up

Aug 2 14:14:22.559 UTC: SB10: Ethernet0/0 Init: a/HSRP enabled

Aug 2 14:14:22.559 UTC: SB10: Ethernet0/0 Init -> Listen

Aug 2 14:14:32.560 UTC: SB10: Ethernet0/0 Listen: c/Active timer expired (unknown)

Aug 2 14:14:32.560 UTC: SB10: Ethernet0/0 Listen -> Speak

Aug 2 14:14:32.560 UTC: SB10: Ethernet0/0 Hello out 10.48.96.43 Speak pri 100 ip 10.48.96.44

Aug 2 14:14:35.212 UTC: SB10: Ethernet0/0 Hello out 10.48.96.43 Speak pri 100 ip 10.48.96.44

Aug 2 14:14:38.161 UTC: SB10: Ethernet0/0 Hello out 10.48.96.43 Speak pri 100 ip 10.48.96.44

Aug 2 14:14:40.818 UTC: SB10: Ethernet0/0 Hello out 10.48.96.43 Speak pri 100 ip 10.48.96.44

Aug 2 14:14:42.560 UTC: SB10: Ethernet0/0 Speak: d/Standby timer expired (unknown)

Aug 2 14:14:42.560 UTC: SB10: Ethernet0/0 Speak -> Standby

Aug 2 14:14:42.560 UTC: %STANDBY-6-STATECHANGE: Standby: 10: Ethernet0/0 state Speak -> Standby

Aug 2 14:14:42.560 UTC: SB10: Ethernet0/0 Hello out 10.48.96.43 Standby pri 100 ip 10.48.96.44

Aug 2 14:14:42.560 UTC: SB10: Ethernet0/0 Standby: c/Active timer expired (unknown)

Aug 2 14:14:42.560 UTC: SB10: Ethernet0/0 Standby -> Active

Aug 2 14:14:42.565 UTC: %STANDBY-6-STATECHANGE: Standby: 10: Ethernet0/0 state Standby -> Active

Aug 2 14:14:42.565 UTC: SB10: Ethernet0/0 Hello out 10.48.96.43 Active pri 100 ip 10.48.96.44

Aug 2 14:14:45.245 UTC: SB10: Ethernet0/0 Hello out 10.48.96.43 Active pri 100 ip 10.48.96.44

Aug 2 14:14:48.122 UTC: SB10: Ethernet0/0 Hello out 10.48.96.43 Active pri 100 ip 10.48.96.44



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
cjnwodo Thu, 08/02/2007 - 07:19
User Badges:

Hi,


For routers 1 and 2 to participate in the same HSRP group, they have to be on the same LAN. From the config you showed, they are not on the same LAN. Router 1 is on 158.48.96.42/255.255.240.0 but router 2 is on 10.48.96.43/255.255.240.0

pciaccio Thu, 08/02/2007 - 07:19
User Badges:
  • Silver, 250 points or more

From your configuration you have two routers and an interface off each of them however the ip subnets are different. They need to be on the same subnet in order to track the virtual ip (standby IP). Your HSRP is init because the HSRP hellos are not getting to the interfaces because of their ip subnets differences. You need to configure the routers with a common vlan subnet. then configure HSRP for those interfaces with a virtual IP on the same subnet. This way traffic will go on the active HSRP router and if a failure the standby router will go into effect. Both the virtual IP must be common for both routers....Good Luck...

Jon Marshall Thu, 08/02/2007 - 07:20
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Hi


On router 1 you have 158.48.x.x.


On router 2 you have 10.48.x.x


Is this intentional ?


Jon



rdessert Thu, 08/02/2007 - 08:11
User Badges:

My apologies!! I tried to edit the actual IP address and put 10 in place of 158 and I missed that 158. So much for my attempt at security!


The actual configs are that both interfaces are on the 158.48.x.x

Edison Ortiz Thu, 08/02/2007 - 08:15
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

You are missing a preempt on router2. However, this shouldn't affect router1 from becoming active.


Can you post the show version from router1 ?


Do you have any ACL between these 2 routers ?


The device where they are connected, the switch, is not blocking any multicast packets, isn't it ?

ougryphon Thu, 08/02/2007 - 08:22
User Badges:

From the IOS documentation, it looks like the hello and holdtimes should not be zero. The default values are 3 and 10 seconds respectively. Doing a quick search, I didn't see any documentation about what would happen if these values were 0, but you might try changing them to the defaults and see if the router comes up as the active router.

glen.grant Thu, 08/02/2007 - 08:29
User Badges:
  • Purple, 4500 points or more

You might want to change your duplex to match on each side , one side is full duplex and the other is half which is a duplex mismatch . Set router 2 to half duplex and see if anything changes.

Hi...


Use the below template on both routers and you will have no problem..


Primary Router

------------------------------

interface FastEthernet0/0

ip address

standby 1 ip

standby 1 timers 5 15

standby 1 priority 105

standby 1 preempt

standby 1 track Serial0/0 ! check interface


backup Router

-----------------------------

interface FastEthernet0/0

ip address

standby 1 ip

standby 1 timers 5 15

standby 1 preempt

rdessert Thu, 08/02/2007 - 11:10
User Badges:

Thanks for all the suggestions. I will be able to work on this again tomorrow and will let you know how it goes.


Rich

Actions

This Discussion