Port forwarding for VOIP

Unanswered Question
Aug 3rd, 2007

Our VOIP quality of service is very poor, so I contacted our VOIP provider and they said one solution could be to set up port forwarding on the ip addresses assigned to the phones.

With our configuration, I'm not sure how to accomplish this. The phones pull a dhcp ip, so I would have to set these to static, then somehow specify these ips to "port forward" 15044 UDP.

Any idea how I can set up port forwarding for port 15044 UDP for these IPs based on my current config?

Thanks,

Will...

Current configuration : 11655 bytes

!

version 12.4

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

boot-start-marker

boot system flash c2800nm-advsecurityk9-mz.124-11.XJ.bin

boot-end-marker

!

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool sdm-pool1

import all

network 10.10.10.0 255.255.255.0

dns-server 209.244.0.3 209.244.0.4

default-router 10.10.10.1

!

ip dhcp pool VPN

host 10.10.10.150 255.255.255.0

hardware-address 0003.a08a.e286

client-name VPNConcentrator

multilink bundle-name authenticated

!

!

vlan internal allocation policy ascending

interface Null0

no ip unreachables

!

interface FastEthernet0/0

description $ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$$ES_LAN$$ETH-LAN$$FW_INSIDE$

ip address 10.10.10.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

ip route-cache flow

duplex auto

speed auto

no mop enabled

!

interface FastEthernet0/1

description $ES_WAN$$ETH-WAN$$FW_OUTSIDE$

ip address <external interface> 255.255.255.252

no ip redirects

no ip unreachables

ip nbar protocol-discovery

ip nat outside

ip virtual-reassembly

ip route-cache flow

duplex full

speed 100

no mop enabled

service-policy output SDM-Pol-FastEthernet0/1

!

interface FastEthernet0/2/0

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

ip route 0.0.0.0 0.0.0.0 <external interface> permanent

!

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 5 life 86400 requests 10000

ip nat pool DynamicIPs <ip_range> netmask 255.255.255.224

ip nat inside source list 1 pool DynamicIPs overload

ip nat inside source static tcp 10.10.10.129 22 <outside_ip> 22 extendable

!

logging trap debugging

access-list 1 remark SDM_ACL Category=2

access-list 1 remark INSIDE_IF=FastEthernet0/0

access-list 1 permit 10.10.10.0 0.0.0.255

no cdp run

!

!

!

!

control-plane

!

banner login ^CAuthorized access only!

Disconnect IMMEDIATELY if you are not an authorized user!^C

!

line con 0

login local

transport output telnet

line aux 0

login local

transport output telnet

line vty 0 4

privilege level 15

login local

transport input telnet

line vty 5 15

privilege level 15

login local

transport input telnet

!

scheduler allocate 20000 1000

!

end

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
wochanda Fri, 08/03/2007 - 10:35

I don't see any possible benefit port-forwarding would do here. All it really helps out with is bridging broadcast traffic between routed domains.

Have you thought about QoS?

Actions

This Discussion