IPIPGW H323-H323 IVR, DTMF, Digits not collected

Unanswered Question
Aug 3rd, 2007


I have 2821 configured as ipipgw h323-h323 with app_debitcard tcl script.

Everything working fine. Voice prompts played, but when script asking for

pin number - digits do not get collected, no response when * or # pressed either.

Script times out 3 times and disconnects.

I have tried different dtmf-relay settings, nothing works.

When application is removed from dial-peer and call sent directly to termination

gateway, dtmf passed through on both legs and working fine when accessing voice mail on termination end.

System image file is "flash:c2800nm-adventerprisek9_ivs-mz.124-11.T.bin"

dial-peer voice 1 voip

service debitcard

incoming called-number .

dtmf-relay h245-alphanumeric

codec g711ulaw


dial-peer voice 2 voip

destination-pattern .

session target ipv4:

dtmf-relay rtp-nte

codec g711ulaw

I can not find any solution or similar problem anywhere.

Please help.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
drolemc Fri, 08/10/2007 - 06:41

On the termination voice gateway the first line of the debug voip ccapi inout call trace as shown below will be a cc_api_call_setup_ind message with a peer_tag option that refers to the inbound VoIP dial peer on the termination gateway

tareqrebhi Thu, 05/08/2008 - 23:17

I have same case here,

I configured my IVR system at AS5400 with IOS c5400-is-mz.123-10f.bin using tcl app_clid_4digits_npw_3.2.0.0.tc.I need to configure prepaid calling card using cisco pre-defined tcl script.

Tcl can play the prompts enter_account.au it is ok and I put my pin number as generated from my billing it is ok too… but when finished entering the correct generated pin number I heard 4 discontinuous tone not like busy tone and then the call disconnect and give me tone as you finished call or hang the speaker again for other call… the prompt enter_dest.au is not started I don't know why?

I attached my AS5400 configuration and its debug report.

Please any body show me where the error exact.

Thank you for any helping.



This Discussion