STP portfast and 802.1q

Answered Question
Aug 3rd, 2007
User Badges:

Hi guys,


Is there anyway to use both "spanning-tree portfast" and "switchport mode trunk" at the same time at the same interface ?


I did the config but I did not get the expected result ! As you can see at the configs below, I?ve configured two ports:


fa0/1 = portfast + trunk 802.1q

fa0/2 = portfast just


~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 22

switchport mode trunk

speed 100

duplex full

spanning-tree portfast

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

interface FastEthernet0/2

switchport access vlan 21

switchport mode access

speed 100

duplex full

spanning-tree portfast

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~


The results of show spanning-tree shows that the first port has not became an Edge port, but second one yes !


Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------


Fa0/1 Desg FWD 200000 128.64 P2p

Fa0/2 Desg FWD 200000 128.65 Edge P2p


Does anyone have a clue about what is happening here ?


Thanks a lot,

Ricardo

Correct Answer by Pari Thiagasundaram about 9 years 11 months ago

Use the command "spanning-tree portfast trunk"

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Pari Thiagasundaram Fri, 08/03/2007 - 13:10
User Badges:
  • Silver, 250 points or more

Use the command "spanning-tree portfast trunk"

Actions

This Discussion