HTTP POST question

Unanswered Question
Aug 6th, 2007
User Badges:

Hello All,

Iam currently working on creating services for the cisco ip phones. Iam using IP communicator2.0 with call manager 3.0.I have a requirement by which i want to push an alert onto the phone screen without the services button of the IP communicator being pressed. Iam aware that the web server can send a HTTP POST onto the communicator. But iam not sure whether the web server of the IP communicator is running or not. Iam not able to receive any request to port 80.

Is the web server of the IP communicator running on a different port? or is there any other work around to acheive an XML object push onto the IP communicator.


Regards,

Stephen

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
msabir Mon, 08/06/2007 - 05:52
User Badges:
  • Bronze, 100 points or more

Web server runs on IP communicator on the same port as IP phones -- that is port 80 by default. I am able to do HTTP Post on IP communicator and run CiscoIPPhoneExecute object on it.

stephenwalter Tue, 08/07/2007 - 05:06
User Badges:

Thanks for the response it was actually the firewall that was causing the issue i disabled it and was able to communicate with phone's web server


Anyway i was able to send a POST to the phone's web server and also got a 200 OK response for it with an xml body as . But the XML object that

i added to the POST is not getting displayed on the phone. The following is the POST request i had sent to the ip phone


POST /CGI/Execute HTTP/1.1

Host: xxx.xxx.xxx.xxx:80

Connection: Close

Date: Mon, 06 Aug 2007 09:05:38 GMT

Server: Microsoft-IIS/6.0

X-Powered-By: ASP.NET

Authorization: username="suresh"

Content-Type: text/xml

Content-Length: 204

Cache-control: private



Title

Select the option


Menu

http://xxx.xxx.xxx.xxx/CiscoServices/airline/airlines.asp




Let me know if there is an issue with the POST request

stephenwalter Thu, 08/23/2007 - 03:06
User Badges:

Hi guys,

Sorry for the late response. I tried adding the URL as an CiscoIPPhoneExecute object like


http://xxx.xxx.xxx.xxx/Login.aspx?/>


and Iam getting the following response


HTTP/1.1 200 OK

Content-Type: text/xml

Date: Thu, 23 Aug 2007 05:26:57 GMT

Cache-Control: no-cache

Expires: Wed , 25 Oct 1995 18:30:00 GMT

Content-Length: 32

Server: Allegro-Software-RomPager/4.20



="0" />


but no GET operation is being done for the URL i give in the Execute Item tag. Am I missing something here?


regards,

Stephen

stephan.steiner Tue, 08/28/2007 - 00:35
User Badges:
  • Silver, 250 points or more

What makes you think that if you get back something that contains the word error, the operation has been properly executed? It hasn't.


Error 0 is one of the elusive ones you can't quite properly track down.. usually it is solved by rebooting the phone or the cluster.

Actions

This Discussion