2801 to 2950 trunk large error bursts

Unanswered Question
Aug 6th, 2007

Hi all,

Recently implemented a new 2801 802.1q trunk to a 2950 switch, every 3 seconds we get a burst of around 1,000 input errors on the 2801 router, but nothing shown on the interface on the switch.

We've replaced:

2801 router

Cables between the two (twice)

swapped the ports on the 2950 switch (swapping out isn't really a simple option at present)

Can anyone suggest why we might be seeing this as it seems a very standard setup, and one that we have in many other sites without problems.

2801 config:

interface FastEthernet0/1

description Switch LAN

no ip address

speed 100

full-duplex

!

interface FastEthernet0/1.1

encapsulation dot1Q 1 native

ip address 10.10.10.1 255.255.255.248

no snmp trap link-status

on the 2950:

interface FastEthernet0/1

description **UPLINK**

switchport trunk allowed vlan 1,123,126,140,142,152

switchport mode trunk

speed 100

duplex full

!

Help!!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
andybonyx Mon, 08/06/2007 - 06:43

Silly me, it helps if I show you the output of sh int fe0/1 on the 2801 router:

FastEthernet0/1 is up, line protocol is up

Hardware is Gt96k FE, address is 001b.d4a8.e9ef (bia 001b.d4a8.e9ef)

Description: Switch LAN

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 2/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 494000 bits/sec, 201 packets/sec

5 minute output rate 1037000 bits/sec, 194 packets/sec

3319239 packets input, 1095006885 bytes

Received 395281 broadcasts, 0 runts, 0 giants, 0 throttles

2990410 input errors, 1525 CRC, 0 frame, 1 overrun, 0 ignored

0 watchdog

0 input packets with dribble condition detected

3247271 packets output, 2459860913 bytes, 0 underruns

0 output errors, 0 collisions, 4 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

And on the 2950 switch:

FastEthernet0/2 is up, line protocol is up (connected)

Hardware is Fast Ethernet, address is 0013.7f66.2a42 (bia 0013.7f66.2a42)

Description: **UPLINK**

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 2/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, media type is 100BaseTX

input flow-control is unsupported output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:01, output 00:00:00, output hang never

Last clearing of "show interface" counters 23w5d

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 1176000 bits/sec, 214 packets/sec

5 minute output rate 544000 bits/sec, 216 packets/sec

31641533 packets input, 3327594976 bytes, 0 no buffer

Received 2236903 broadcasts (0 multicast)

0 runts, 0 giants, 0 throttles

12 input errors, 8 CRC, 4 frame, 0 overrun, 0 ignored

0 watchdog, 218798 multicast, 0 pause input

0 input packets with dribble condition detected

133611358 packets output, 1567316521 bytes, 0 underruns

0 output errors, 368 collisions, 2 interface resets

0 babbles, 0 late collision, 1691 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

rickyt888 Mon, 08/06/2007 - 09:55

On your switch port interfaces, apply the

"switchport trunk encapsulation dot1q"

Hope this help.

andybonyx Mon, 08/06/2007 - 23:38

Thanks for the advice, however this is a new 2950 switch, with new IOS (12.1(22)EA2) which uses dot1q as native, so doesn't need or accept this statement.

Encapsulation is definately working, as the switch/trunks are operating perfectly, just the errors.

Actions

This Discussion