IP Address Range Change

Unanswered Question
Aug 6th, 2007

Hello

We currently have 3 vlans setup on out 4507 switch they are 10.1.1.0, 10.1.101.0 and 10.1.102.0. we have been told by HQ that we need to migrate all addresses to 10.84.0.0 range. How can i do this in stages without interupting the network. Do i set up a static route to the new range on the switch??

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.7 (4 ratings)
Loading.
Jon Marshall Mon, 08/06/2007 - 14:19

Hi Luke

Not sure what you mean by static route. Are the L3 vlan interface for your existing vlans on the 4507R ?

If so you could just create a new vlan + Layer 3 SVI for the 10.84.0.0 range and then migrate machines into this vlan making sure you update the default gateway.

If it is more complicated than this please let me know.

HTH

Jon

JORGE RODRIGUEZ Mon, 08/06/2007 - 17:56

you can do this by creating new vlan interfaces using the 10.84.0.0 range and slowly migrate your hosts from 10.1.1.0, and 10.1.102.0 to the newly created 10.84.0.0 vlans.

HTH

Jorge

lukekinson Mon, 08/06/2007 - 23:57

Sorry for being a pain Jorge but what command do i need to use to add this new vlan and once i start moving machines into the new vlan will they still be able to communicate with the other vlans?

Thank You

Luke

Jon Marshall Tue, 08/07/2007 - 01:07

Luke

You need to create the vlan at Layer 2 and then create a layer 3 interface for it.

to create layer 2 vlan from config mode

vlan "vlan number"

name Newvlan

then to create Layer 3 SVI from config mode

interface vlan "vlan number"

ip address 10.84.x.x

no shut

Yes they will be able to communicate with the other vlans. Just make sure that you set the default gateway of any machines you move into the new vlan to be the Layer 3 SVI ip address you have just created.

HTH

Jon

JORGE RODRIGUEZ Tue, 08/07/2007 - 08:41

Hi Luke not a pain please ask, can you briefly discribe the LAN and also provide a "show run " from the switch as well as

" show mod " "show version " and " show cdp neighbors" " show vlan " we need to see the role of this switch.

basically you need to look at your config and how the current VLANS are created and if indeed this switch is doing the intervlan routing. Is this switch your CORE switch or is there an upstream router doing the intervlan routing. ALso how is your DHCP implemented, aere you doing static or DHCP for your PCs.

if you have the SVI interfaces created on this switch for you would see in teh config similar info as follows:

this is an example

interface vlan102

ip address 10.1.102.1 255.255.255.0

then your user ports

interface fastethernet1/20

switchport access vlan 102

Now, determined the subnets given to you that need to be migrated.. you said you were given 10.84.0.0 did they give you more details like mask information .

creating a new SVI for a /24 bit subnet

interface vlan 184

ip address 10.84.0.1 255.255.255.0

no shutdown

then configuring the vlan port memeberships.

say you have one PC ins FE1/40 in the old vlan 102, you need to move it to the new vlan 184

eg.

interface fastethernet1/40

switchport access vlan 184

lukekinson Tue, 08/07/2007 - 23:34

Hi Jorge

The switch is indeed our core switch. All our pc's pick up IP addresses by DHCP although the servers and printers have been given static ip addresses. We have been given a class B subnet to use, 255.255.0.0. At present my pc is in the 10.1.1.0 range and i cannot ping anything in the 10.1.101.0 or 10.1.102.0 range which suggests there is no intervlan routing setup. I have emailed you txt files of all the show commands you asked for as im only allowed 3 attachements per post

Thanks very much for all your help

Luke

JORGE RODRIGUEZ Wed, 08/08/2007 - 17:41

Luke, sorry for the late reply.. I just received your text.. also it is safe to share the text in this forum as no public informtion is found since you are working from the inside your lan.. so feel free to attach the file you emailed me to this thread for others to see and comment as well, would it be ok to attach your config in this thread ?

I looked at the config, lets take it by sections at a time.You have 3 vlans,

vlan1-ip address10.1.1.254/24,vlan3- ip address 10.1.102.254/24, and vlan4-IPaddress 10.1.101.254/24. All your machines are in the management vlan1 and you cannot ping anything in the 10.1.101, and 102 subnet.

first take care of this add the following into the routing process, but it seems since you have so many static routes fo 10.1.1.0

you are not realy using eigrp at all, but add these two lines .

e.g

router#config t

router eigrp 1

network 10.1.0.0

network 10.84.0.0->may as well add for newnet

exit

write mem

also send " show ip eigrp neighbors "

and " show ip route "

also these static routes are not going anywhere but to itself, so remove these routes.

ip route 10.1.101.0 255.255.255.0 Vlan4

ip route 10.1.102.0 255.255.255.0 Vlan3

on the vlans you indicated you cannot ping I believe you are not passing vlan3 and vlan4 in the configured trunks to your down stream switches since

evrything seems to be in Vlan1 10.1.1.0, if the trunks proves you are passing vlan3 and 4, then you need to add ports to vlan3 and 4 respectivately in the switches trunking to the core.

can you issue this command

" show interface trunk " and post the text.

after this is fixed we'll move into creating the new vlans in the database and the SVI interfaces for the new required networks .

lukekinson Thu, 08/09/2007 - 01:18

Hi Jorge

thanks for replying you are being a massive help:-) I attempted to perform the instructions and have attached in the instructions.txt file the results. I have also attached the results of the show interface trunk command

Many thanks

Luke

JORGE RODRIGUEZ Thu, 08/09/2007 - 06:40

Luke, for now lets put aside eigrp as see in the config all your routing is via static. In order from this core switch to do intervlan routing within this switch to and from vlan1, 3 and 4 you need to enable ip routing. Also make sure you have at all time console cable in the event you need to console to the switch/router.

connect to switch and issue this script.

Cat4507R#config t

Cat4507R#(config)#ip routing

Cat4507R#(config)#exit

if not done so bring up vlan3 and 4

Cat4507R#config t

Cat4507R(config)#interface vlan3

Cat4507R(config-if)#no shut

Cat4507R(config-if)#exit

Cat4507R(config)#interface vlan4

Cat4507R(config-if)#no shut

Cat4507R(config-if)#exit

Cat4507R#

try ping from this router its SVI interfaces

ping 10.1.102.254, 10.1.101.254, and 10.1.1.254.. and see if interfaces reply to pings from within.

let me know how this part goes, I'll be cheking forum in about an hour or so.

Jorge

lukekinson Fri, 08/10/2007 - 00:06

Morning Jorge

I have completed the instructions and they appeared to all be successful. I have attached a txt file showing you the results. Once again many thanks for your help on this you are a life saver :-)

Luke

Attachment: 
JORGE RODRIGUEZ Fri, 08/10/2007 - 05:17

before we move onto the next step do you have dhcp scopes created for vlan3 and vlan4? and what is your dhcp IP address, we need to add the dhcp ip address as helper address in vlan3 and vlan4 so that machines that are in these vlans 3 & 4 can suuccessfuly pickup IP address from dhcp.. once we get this info I'll post the script for ip helper address configuration.

BTW.. these whole process will be done for the new subnets requirements on the 10.84.0.0 networks..

Rgds

Jorge

lukekinson Fri, 08/10/2007 - 13:24

Hi Jorge

The amount of devices in vlan 3 and 4 are relativley small so they all have static ip addresses not dhcp. After adding the static routes i can now ping 10.1.101.254 and 10.1.102.254 but no other addresses in those vlans

Thanks Jorge

Luke

JORGE RODRIGUEZ Fri, 08/10/2007 - 14:33

Hi Luke, where are you pinging from vlan1 10.1.1.0 ? what static routes have you applied and on which router device?

make sure devices on vlan 3 and 4 are configured with their respective gateway and that indeed are in vlans 3 or 4.

what you need to do next if assign ports to vlan 3 for the sake of test.

in any of your down stream switches where PC's are connected take any host and configure it with static IP

for vlan3 10.1.102.0 , note the port the PC will connect to. Say you have a PC connected to port 24 on switch-1.

By default all fe ports are auto sence for transmission , you may want to do the same for PC NIC speed dup auto.

example:

PCIP: address: 10.1.102.10

MASK: 255.255.255.0

DG: 10.1.102.254

switch-1#config t

switch-1(config)#interface fastethernet0/24

switch-1(config-if)#switchport access vlan 3

switch-1(config-if)#no shut

switch-1config-if)#exit

switch-1(config)#exit

switch-1#write mem

once PC is connected to port 24 ping the gateway from it, 10.1.102.254, and also any host on the 10.1.1.0 subnet.

To configure a range of ports say ports 1 throught 10 instead of one by one do as follows:

switch-1#config t

switch-1(config)#interface range fa0/1 - 10

switch-1(config-if-range)#switchport access vlan 3

switch-1(config-if-range)#no shutdown

switch-1(config-if-range)#

have you come up with the IP subnet scheme for the 10.84.0.0 let me know if you have to start creating the vlans and

the SVI in the core switches, since you need to migrate all of your 10.1.1.0 10.1.102.0 and 10.1.103.0 to

the new network you should move forward but test the above configuration so you follow the principle.

Jorge

lukekinson Tue, 08/14/2007 - 03:52

Hi Jorge

Sorry I havent responded to the forum, only checked it this morning as I have been on holiday until now. I have now been given a detailed plan of how we will need to set up the ip addressing in the company. As i have already mentioned we wll be moving to a 10.84.0.0 range using 255.255.0.0 as our subnet mask. the 1st host digit will correspond to the type of machine ie

1= network equipment

2= Servers

3=Printers

10=Workstations etc etc

I have also done a scan of the 10.1.102.0 vlan and there are no machines using this range of addresses so it can be deleted ( could you plese expain how i go about this :-) )

After some thought we will not be using vlans from the start of the migration so all we need to be able to do is to have connectivity between the 10.1.1.0, 10.1.101.0 and the new 10.84.0.0 ranges. Is this easily done?

Hope im not being too much of a pain

Many Thanks

Luke

Luke Kinson

JORGE RODRIGUEZ Tue, 08/14/2007 - 13:11

luke, can you email me your network diagram if you have any.. we'll take it from there.

JORGE RODRIGUEZ Tue, 08/14/2007 - 17:44

email me or attach a network diagram to see your LAN and Edge connectivity to HQ.

to remove vlan3 pertaining to 10.1.102.0 subnet and its SVI do as follows on your core switch, also

remove static routes pertaining to it.

Cat4507R#vlan database

Cat4507R(vlan)#no vlan 3

Cat4507R(vlan)#exit

Cat4507R#config t

Cat4507R(config)#no interface vlan 3

Cat4507R(config)#no ip route 10.1.102.0 255.255.255.0 Vlan3

Cat4507R(config)#exit

Cat4507R#clear ip route 10.1.102.0

you could use 10.84.1.128/25 for internal network devices this will give you 126 IP addresses.

10.84.1.128/25 ( net management interfaces )

10.84.2.0/16 for Server ( 254 hosts )

10.84.3.0/16 printers ( 254 hosts )

10.84.10.0/16 workstations(254 hosts)

for your your servers segment, printers and workstation just create the vlans and its interfaces

Cat4507R#vlan database

Cat4507R(vlan)#vlan 5 name servers_segment

Cat4507R(vlan)#vlan 6 name printers_segment

Cat4507R(vlan)#vlan 7 name Workstations_segment

Cat4507R(vlan)#exit

Cat4507R#show vlan ( verify new vlans are there )

create new SVI for the new vlans

Cat4507R#config t

Cat4507R(config)#interface vlan5

Cat4507R(config-if)#ip address 10.18.2.254 255.255.0.0

Cat4507R(config-if)#Description Server_Segment

Cat4507R(config-if)#no shut

Cat4507R(config-if)#exit

Cat4507R(config)#interface vlan6

Cat4507R(config-if)#ip address 10.18.3.254 255.255.0.0

Cat4507R(config-if)#Description Printer_Segment

Cat4507R(config-if)#no shut

Cat4507R(config-if)#exit

Cat4507R(config)#interface vlan7

Cat4507R(config-if)#ip address 10.18.10.254 255.255.0.0

Cat4507R(config-if)#Description Workstations_Segment

Cat4507R(config-if)#no shut

Cat4507R(config-if)#exit

in your downstream switches make sure you assign a port for a workstation vlan 7, configure PC

with a new IP scheme from 10.18.10.0 and ping its respective gateway 10.18.10.254, also from

PC ping any host on 10.1.1.0 and 10.1.101.0 subnets.

Actions

This Discussion