7206 Router Fast Ethernet interface Line Protocol Down.

Unanswered Question
Aug 6th, 2007

Hello all.

I have a Cisco 7206 router running IOS version 12.2(8)T10. When I enable the Fast Ethernet interface I see that the line protocol is down.

When I run the command show controllers I see the following :

#show controllers fastEthernet 0/0

Interface FastEthernet0/0

Hardware is DEC21140A

link down, reason: MII link down

What are the reasons for having Line Protocol be Down, and what does "MII link down" error mean?

Any help would be greately appreciated.

Thank you.

Dmitry.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
JORGE RODRIGUEZ Mon, 08/06/2007 - 16:18

Dmitry, few things.. the I/O type controler installed on that 7206 router has one builtin MII port and a RJ45 port for FE connection., are you using the RJ45 port for connecting it to a switch or the MII port using a transceiver.

line protocol down could be duplex missmatch, but from what I see in your show controllers is unclear as to what you are using to connect to a switch, or hub, or anything.

can you provide

" show ip interface brief "

dtochilovsky Mon, 08/06/2007 - 18:25

I am using the RJ45 port to connect to another switch.

The interface was working for a long time but suddenly stopped and we had to disable it as the line protocol is down.

#show ip interface brief

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 A.B.C.D YES NVRAM up down

#sh int fastEthernet 0/0

FastEthernet0/0 is up, line protocol is down

Hardware is DEC21140A, address is 0002.1727.4000 (bia 0002.1727.4000)

Description: EGRESS to INTERNET

Internet address is A.B.C.D/28

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

#sh diag

Slot 0:

Fast-ethernet on C7200 I/O card with MII or RJ45 Port adapter, 1 port

Port adapter is analyzed

Port adapter insertion time 2y0w ago

EEPROM contents at hardware discovery:

Hardware revision 2.1 Board revision B0

Serial number 15783391 Part number 73-4092-03

FRU Part Number: C7200-IO-FE-MII/RJ45=

Test history 0x0 RMA number 00-00-00

EEPROM format version 1

EEPROM contents (hex):

0x20: 01 83 02 01 00 F0 D5 DF 49 0F FC 03 00 00 00 00

0x30: 58 00 00 00 00 03 05 00 00 00 FF FF FF FF FF FF

spremkumar Mon, 08/06/2007 - 19:28

Hi

Can you revert on the other end device ? is this router connecting to a switch/firewall etc., if yes did u check the port status interface status both physically as well as with cli on the box ?

regds

JORGE RODRIGUEZ Tue, 08/07/2007 - 03:52

Dmitry, have you configured the FE interface with any ipv4 address.

e.g.

interface fastethernet0/0

ip address 2.2.2.1 255.255.255.0

Pavlo Bykov Tue, 08/07/2007 - 08:01

Do you have media type configured?

Have you checked cabling (i.e. connecting PC/Switch to the router directly to that port without all the infrastructure) ?

We had similar problem when our structured cable started malfunctioning.

dtochilovsky Tue, 08/07/2007 - 11:00

Media type is not configured, it is default 100BaseX.

I even tried changing it to MII and then back to 100BaseX, still not working - line protocol stays Down.

Also testing the interface produced these results :

SBC-Outside-Primary-7206#test interfaces fastEthernet 0/0

... Failed - not connected problem

1 interfaces: 0 passed, 1 failed, 0 skipped, 0 untestable

We will try and change out the cable connecting the router to an Upstream switch, and check the port on that switch, to make sure that is not the problem.

Thank you for the suggestion. I suspect it is a cable issue.

JORGE RODRIGUEZ Tue, 08/07/2007 - 11:37

like you said it could be cabling..

I would also check duplex settings on the switch port and vlan information as well.

dtochilovsky Wed, 08/08/2007 - 08:17

I rebooted the router this morning and got the following message:

%DEC21140-5-NOCARR: FastEthernt 0/0 cable/connector problem?

I know that it refers to cable or transceiver failure. So I will investigate the cabling or try replacing the controller.

Actions

Login or Register to take actions

This Discussion

Posted August 6, 2007 at 2:44 PM
Stats:
Replies:9 Avg. Rating:
Views:1170 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard