1811W router unable to get DHCP IP from Speedstream 4100

Unanswered Question
Aug 6th, 2007

I have a Yahoo-ATT DSL installation with 1 dynamic IP address. It uses an ISP supplied speedstream 4100 DSL modem. The 4100 appears to take care of all the PPOE duties and DHCP connections from PCs or low-end routers (I'm temporarily using a NetGear unit) work fine.

BUT, when I swap the Netgear out for my new 1811W, the cisco unit is unable to obtain a DHCP address from the modem. I can see the request on the modem lights when I do a "no shutdown fastethernet0"...but I never get an IP address.

The speedstream appears to support 100Mbps and I have tried 100, 10 and Auto on the 1811W. I can look at the log on the modem and it does not show any activity by the modem's dhcp service. However, when I swap back to the netgear unit, I can see appropriate entries in the modem log.

The 1811 is new and I strongly suspect its working ...I tested it on a different DSL line that had static IP. I see a number of similar issues in this forum; but have not seen any resolution that seems to fit my situation.

Any help/suggestions would be appreciated...my next step will be log the DHCP packets with a sniffer. I think I know what I"ll see...1811W DHCP broadcast...no response. But, that won't help me resolve the issue.

Thanks,

Chuck McP

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Mon, 08/06/2007 - 17:26

Sometime, cisco routers have problem in getting DHCP address from ADSL modems, as cisco uses a "client-id" field that is a bit different from what PCs uses.

Can you check if 4100 is configuresd for bridging or NAT? The first mode would be preferable as you would be able to termina PPPoE or IPoA directly on the 1811.

rtis_cisco Tue, 08/07/2007 - 11:27

Thanks for the suggestion. The modem is in NAT mode w/PPOE performed on the modem. As I understand it, that's the only config ATT Yahoo supports.

I have found info on how to change the 4100 to bridge mode; but, again as I understand things, that pushes the PPOE processing into the router.

Any pointers around on how to configure that? I don't think I will get much help from the ISP once I leave NAT mode, so the more I know about the guts at this low level, the better my chances of success.

Thanks,

Chuck McP

rtis_cisco Tue, 08/07/2007 - 11:31

BTW, I'm surprized that there isn't a Cisco tech note on this exact problem. The 4100 (which I believe replaces the 5100b) is being shipped by lots of ISPs. And, I rarely seem to run into network problems that have not already been seen (and solved) by lots of other admins - or Cisco TACs. (...sigh....)

Chuck McP

Paolo Bevilacqua Tue, 08/07/2007 - 12:55

Hi, this would a config example once you configure the dsl modem for bridging:

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a0080126dc0.shtml

look at the 2600 part. you can omit these commands that are for older versions:

vpdn enable

no vpdn logging

!

vpdn-group 1

request-dialin

protocol pppoe

Hope this helps, please rate post if it does!

slayerhawk Tue, 09/11/2007 - 13:04

We have a very simlar issue. We just did a new install with an 1811. If we used bridge mode on the 4100B we had to use a dialer interface on the 1811 to pass username/password to the DSL modem. This would not work with our dial back up scheme.

With the attached config, running the dsl modem in pppoe on modem mode, we work for DSL and dial backup, but after a power cycle of the dsl modem the circuit won't come back up unless we 1st connect a laptop up to the dsl, then plug it back into fa0 of the 1811.

Can anyone shed some light on this?

Actions

This Discussion