cpu reach 90%

Unanswered Question
Aug 7th, 2007

hello

I have cisco 2811 that connected to a satellited modem in its serial interface and to internal network via its FastEthernet

I enabled WCCP V2 to redirect the traffic to my Squid server but the cpu reach 90% despite the fact the bandwidth is less that 15 Mbps

when I enabled "ip route-cache same-interface " in the FastEthernet int. the cpu load dropped down dramatically from 90% to 15% but another problem comes to the play ,after I enabled the "ip route-cache same-interface " I had problem with emails site like yahoo and gmail , I got the page cannot be displayed error.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (3 ratings)
Loading.
Pavel Bykov Tue, 08/07/2007 - 09:09

Well, your CPU load problem definitely seems to be with switching type. All switching today is done primarily in HW, so without "route-cache" it loads CPU quite a lot.

I'm thinking if for some reason WCCP is tied to switching type, and need clearing when switching type is changed (reboot).

Paolo Bevilacqua Tue, 08/07/2007 - 12:34

slidersv, allow me a small correction. on all routers up to the 7200, routing is done in software. It can be a more efficient software like cef, or a slower one like "process switching", but still it is all and only software running on router CPU.

Pavel Bykov Tue, 08/07/2007 - 12:53

Thanks for the correction. That's why it's called a "Software platform".

wochanda Tue, 08/07/2007 - 11:50

What is happening is that since the lookup decision made by CEF is to send the packet out the same interface it came in on, the packet is being punted to the process path for an ICMP redirect to be generated.

The easiest fix here is to turn off this behavior by doing a 'no ip redirects' under the interface the packets are coming into/going out of. This'll allow CEF to forward the packets without sending them to the process path for the redirect.

pinkheart Wed, 08/08/2007 - 03:10

first of all I wanna thank you for your valuable information,

I didn't enabled "ip cef" globally

when I added "ip cef " command in global configuration and then I added "ip route-cache same-interface " in the FastEthernet int. everything works perfectly.

so I guess the missing commands was "ip cef"

thanks again

Actions

This Discussion