ASDM is unable to read the configuration from ASA.

Unanswered Question
Aug 7th, 2007

Earlier today I was configuring the Cisco ASA (7.2(2)) using the ASDM, but after a reboot of the appliance I now get the following:

ASDM is unable to read the configuration from ASA.

This happens shortly after ?Loading running configuration from the device? appears in the ASDM status window.

I have tried restarting both the appliance and my workstation, but the issue persists. I have also tried clearing the ASDM cache, but that doesn?t help either. The issue occurs whether I used the Cisco ASDM Launcher or the web interface.

SSH access to the appliance works fine.

Thanks for any assistance (why is it that Cisco?s GUIs always have issues?!?).

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
rochopra Wed, 08/08/2007 - 04:13

What is the version of ASDM file you have on ASA.

I have seen Asdm ver 5.2.2 works fine with ASA ver 7.2.2


drigoldi Tue, 11/25/2008 - 05:32

I have exactly the same issue , SSH works fine but ASDM and Web interface reply with that error message "ASDM is unable to read the configuration from ASA".

My ASA is a 5520 ver 7.1(2) with ASDM 5.1(2)

Could it be something related to Java ?

Thanks for any hint.

drigoldi Tue, 11/25/2008 - 08:34

I solved the problem re-installing JAVA 6 Update 7.


julomban Thu, 11/27/2008 - 15:57

The java update 10 is not compatible with asdm. You will need to downgrade the java version to update 6 or 7.

drigoldi Fri, 11/28/2008 - 07:28

Thank you very much, I noticed on the community I'm not the only one who had such an issue.

With Java 6.0 update 7 i'm gold.

Thanks again


This Discussion