IOS file [invalid checksum]

Unanswered Question
Aug 7th, 2007

Hi there,

I've recently bought a Cisco 2500 to test with off of an online auction site. The first 2 days I had it powered on and did some basic config on it and everything was fine. I left it powered on over the weekend and when I checked it on Monday I noticed that it had (boot) next to the hostname. I checked the IOS file in flash and it had an [invalid checksum] next to it. I've tried erasing the flash and copying the IOS file over again via tftp and even though it seems to copy over fine(the size of the file in flash is the same as the original), it fails the checksum verification and still has [invalid checksum] so the router isn't booting properly. I don't have other flash memory to test whether the problem is a hardware one but is there something else I can try? Did I just buy a dud?

Cheerio.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
guruprasadr Tue, 08/07/2007 - 20:55

HI Cheerio,

If possible you can try by "Formatting the Flash" Card once and redo your work.

Also, try downloading the same IOS file from Cisco.com site and Check again.

Pls Rate if Helps

Best Regards,

Guru Prasad R

geewizz09 Wed, 08/08/2007 - 15:35

Hey Guru,

I dont have the option to 'format' the flash memory from exec mode, only erase. Perhaps these two commands mean the same thing just for different types of flash file systems?

Cheers.

geewizz09 Sun, 08/12/2007 - 19:43

The issue could be the IOS image but I don't have the right login to download one off the cisco.com site :/

guruprasadr Sun, 08/12/2007 - 20:25

HI, [Pls Rate if HELPS]

You need a CISCO "CCO" account with respective privileges to download the IOS.

You can contact your nearby Cisco Partner (Certified Partner) for getting the IOS or request the Cisco Customer Service for further assistance.

Refer link below:

http://www.cisco.com/warp/public/687/Directory/DirTAC.shtml

PLS RATE if HELPS

Best Regards,

Guru Prasad R

geewizz09 Sun, 08/12/2007 - 21:37

G'day mate,

I realised that since I've only signed up with a guest account. Good idea about contacting a Cisco Partner.

Cheers.

jwdoherty Wed, 08/08/2007 - 06:33

If your flash is large enough, and the image small enough, also try down loading the image without doing an erase. This will use a different portion of the flash.

geewizz09 Wed, 08/08/2007 - 15:37

There's 8Mb of flash memory and the image is around the same so it just fits therefore i have to erase it everytime i try to copy it over again.

Cheers.

deveshkumar Wed, 08/08/2007 - 08:37

its giving you error againg after copying new ios inmage..That means flash is corrupted dude

geewizz09 Wed, 08/08/2007 - 15:49

That's what I'm thinking, but I just wanted to be sure. Was it just my bad luck that it had corrupted just 2 days after I bought it?

Oh well, I'll have another 2500 router within the next couple of days so I'll be able to test the flash memory.

Cheers.

sundar.palaniappan Wed, 08/08/2007 - 16:24

On the PC running the TFTP what's the file system (FAT, NTFS) of the hard drive that you have the IOS image stored on?

sundar.palaniappan Thu, 08/09/2007 - 03:28

I have had some issues a while ago when using NTFS partition to store the IOS image. It may have something to do with the compression. I don't exactly remember how I fixed the problem back then. But if you can can you try another method to download the IOS and copy it over to the router.

HTH

Sundar

dcarlton Thu, 08/09/2007 - 10:22

Try booting it from your tftp server to get a good set of IOS loaded and not the boot loader. Then you should be able to format the flash.

What version of IOS are you using

geewizz09 Sun, 08/12/2007 - 19:40

I've tried booting it via tftp and everything's fine but there's no option to format the flash, only erase.

Here's the output from sh ver:

Cisco Internetwork Operating System Software

IOS (tm) 2500 Software (C2500-JS-L), Version 11.2(26f), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2004 by cisco Systems, Inc.

Compiled Tue 13-Apr-04 22:17 by cmong

Image text-base: 0x00001448, data-base: 0x0076AB0C

ROM: System Bootstrap, Version 5.2(8a), RELEASE SOFTWARE

BOOTFLASH: 3000 Bootstrap Software (IGS-RXBOOT), Version 10.2(8a), RELEASE SOFTWARE (fc1)

Model_101 uptime is 45 minutes

System restarted by reload

System image file is "c2500-js-l.112-26f.bin", booted via tftp from 172.16.12.230

cisco 2500 (68030) processor (revision D) with 16384K/2048K bytes of memory.

Processor board ID 03846450, with hardware revision 00000000

Bridging software.

SuperLAT software copyright 1990 by Meridian Technology Corp).

X.25 software, Version 2.0, NET2, BFE and GOSIP compliant.

TN3270 Emulation software.

1 Ethernet/IEEE 802.3 interface(s)

2 Serial network interface(s)

32K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

Andyfweih Mon, 08/13/2007 - 02:49

Dear business partners & valued customers :

I am pleased to enclose it for your reference.

We can give you better price depending on the items and Qty.

Large quantity new & used Cisco and networking products that aren't

included in this catalogue. Feel free to contact us with your

requirements.

50% discount of GPL!! (Original new, 1 year warranty)

WS-C3560-24TS-S

WS-C3560-48TS-S

WS-C3560G-24TS-S

WS-C3560G-48TS-S

WS-C3750-24TS-S

WS-C3750-48TS-S

WS-C3750G-12S-S

WS-C3750G-24TS-S

WS-C3750G-24PS-S

60% discount of GPL!! (Original new, 1 year warranty)

WS-C3560-48TS-E

WS-C3560-24TS-E

WS-C3750G-24T-E

WS-C3750G-24TS-E

WS-C3750G-24PS-E

WS-C3750G-48TS-E

WS-C3750G-48PS-E

Looking forward to receiving your enquiries soon.

Best Regards

Andy Feng

FEDON(INT'L)DEVELOPMENT LTD

MSN:[email protected]

Email:[email protected]

Http://fweih.diytrade.com

Actions

This Discussion