High CPU Utilization on 6509 with Sup 720

Unanswered Question
Aug 8th, 2007
User Badges:

Please see the following output:

CPU utilization for five seconds: 74.88%

one minute: 76.24%

five minutes: 76.05%


PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process

--- ----------- ---------- -------- ------- ------- ------- --- ---------------

1 0 2837176798 0 25.12% 23.76% 23.95% -2 Kernel and Idle

12 858748620 2667715367 88000 3.22% 3.92% 3.98% -2 IDLE_Tasks

70 273141953 500021728 487000 1.92% 1.00% 1.00% 0 SptBpduRx

71 633933924 404141420 42000 54.86% 55.84% 55.96% 0 SptBpduTx

91 814921690 2723819046 56000 5.96% 5.92% 5.98% -2 SptFlush

189 786158663 2095789840 348000 4.04% 4.00% 4.00% -2 SlcpProcess


What causes the high SptBPDUtx?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
b.speltz Tue, 08/14/2007 - 10:26
User Badges:
  • Bronze, 100 points or more

I think this command will help you : Switch> (enable) show processes cpu

javickas1 Tue, 08/14/2007 - 10:39
User Badges:

Hi and Thanks for the response, however I got the information from the following command:

sh proc cpu | exc 0.00


Showing only the processes chewing up the CPU.

Again thanks for the response.

javickas1 Tue, 08/14/2007 - 11:30
User Badges:

I have read that article, went through the diagnostics and it did not help.... Notice the BPDUrx not the BPDUtx is the concern in the article. Mt BPDU Transmits are high....:-(

valstan Tue, 08/14/2007 - 12:55
User Badges:

Would you be able to try replacing the SUP?

Pavel Bykov Tue, 08/14/2007 - 14:05
User Badges:
  • Silver, 250 points or more

Is this a box with a lot of linecards, where users with IP Phones are connected?


If so, reconfigure all the ports from TRUNK to "switchport access vlan X" and "switchport voice vlan Y"


This will dramatically reduce your CPU load.

Edison Ortiz Tue, 08/14/2007 - 14:39
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

It may be doing an excessive Spanning-Tree calculation, an indication of a loop. Do you have multiple switches connected to this device ?


Are these switches interconnected to each other ?


Can you post some kind of network topology ?


Do you see any errors in the switch's log ?

Actions

This Discussion