Output queue prob, or wiring prob?

Unanswered Question
Aug 9th, 2007

I've got a Cisco 2611 router running an IP-only GD release of 12.2(40). 48MB RAM. I've got a 384K frame-relay port attached to a WIC card; the PVC is 192K. Pertinant parts of 'show interface' are below. Do you think I have a queue problem, or a wiring problem?

Input queue: 0/75/0/0 Total output drops: 96

54 input errors, 52 CRC, 1 frame, 0 overrun, 0 ignored, 1 abort

The interface never goes down on layer3 or layer2; it's always up, but these errors come in abound one every 5-6 seconds or so. Traffic might hit 100% of the PVC speed once every 12 hours, but it does *not* do it constantly.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
wochanda Thu, 08/09/2007 - 06:40

What are you more concerned with here, the output drops or the input errors. The output drops are an indication of oversubscription, even if only for a millisecond. Since the default output queue is 40 packets, all it takes is a single burst of 41+ packets to fill this queue and have a drop, which wont show up on any monitoring tool. If you paste in your FR main/subinterface configuration I can let you know how to make your output queue bigger.

As for the input errors, this usually indicates a line problem. You can try doing loopback tests at different points in your network to narrow it down, or you can just ignore them if they dont have much of an impact. What kind of serial interface module are you using?

abatson Thu, 08/09/2007 - 06:59

Here's the pertinant parts of my config:

_____________________________________________

rtr-TAGS1#show run

Building configuration...

Current configuration : 2753 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname rtr-TAGS1

!

ip subnet-zero

!

no ip domain-lookup

!

ip multicast-routing

ip multicast cache-headers

multilink virtual-template 1

!

!

interface Ethernet0/0

ip address 192.168.147.1 255.255.255.0

ip pim dense-mode

ip cgmp

no ip mroute-cache

half-duplex

!

interface Ethernet0/1

ip address 192.168.149.1 255.255.255.0 secondary

ip address 192.168.150.5 255.255.255.252

ip pim dense-mode

no ip mroute-cache

half-duplex

!

interface Serial0/2

description Frame Relay to the Columbia DOC

no ip address

no ip proxy-arp

encapsulation frame-relay

no ip mroute-cache

no service-module t1 remote-loopback full

service-module t1 timeslots 1-6

frame-relay lmi-type cisco

!

interface Serial0/2.371 point-to-point

description frame-relay to Columbia subinterface

ip address 192.168.146.2 255.255.255.252

no ip proxy-arp

ip pim dense-mode

no ip mroute-cache

no cdp enable

frame-relay interface-dlci 371 CISCO

!

rtr-TAGS1#show int s0/2

Serial0/2 is up, line protocol is up

Hardware is PQUICC with Fractional T1 CSU/DSU

Description: Frame Relay to the Columbia DOC

MTU 1500 bytes, BW 384 Kbit, DLY 20000 usec,

reliability 255/255, txload 18/255, rxload 7/255

Encapsulation FRAME-RELAY, loopback not set

Keepalive set (10 sec)

LMI enq sent 361, LMI stat recvd 361, LMI upd recvd 0, DTE LMI up

LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0

LMI DLCI 1023 LMI type is CISCO frame relay DTE

Broadcast queue 0/64, broadcasts sent/dropped 122/0, interface broadcasts 59357

Last input 00:00:06, output 00:00:00, output hang never

Last clearing of "show interface" counters 01:00:14

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 96

Queueing strategy: weighted fair

Output queue: 0/1000/64/96 (size/max total/threshold/drops)

Conversations 0/6/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 288 kilobits/sec

5 minute input rate 12000 bits/sec, 13 packets/sec

5 minute output rate 28000 bits/sec, 26 packets/sec

62944 packets input, 7651894 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

143 input errors, 137 CRC, 5 frame, 0 overrun, 0 ignored, 1 abort

140261 packets output, 21092377 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

!

SHow interface switching:

!

Serial0/2 Frame Relay to the Columbia DOC

Throttle count 0

Drops RP 0 SP 0

SPD Flushes Fast 0 SSE 0

SPD Aggress Fast 0

SPD Priority Inputs 487 Drops 0

Protocol Path Pkts In Chars In Pkts Out Chars Out

Other Process 0 0 6115 79495

Cache misses 0

Fast 0 0 0 0

Auton/SSE 0 0 0 0

IP Process 3649 247900 812869 129102133

Cache misses 1465

Fast 963444 130889574 1176117 191863603

Auton/SSE 0 0 0 0

abatson Fri, 08/10/2007 - 06:24

Original poster here -- Another interesting test I did proved that even when I'm experiencing CRC errors, I don't drop any packets. I tried pinging with 36-byte packets, and 1400-byte packets, and everything arrives OK with no drops. Does this further implicate a queueing problem?

Actions

This Discussion