qos fro incoming traffic

Unanswered Question
Aug 9th, 2007

Hello dear guys

i want to mark incoming traffic from my specific router to mark with high proirity quese for outgoing purpose

any hint please

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
deveshkumar Fri, 08/10/2007 - 06:36

Hi fren

Use MQC (Modulur QoS Config CLI mode)

prepare acl's to match the traffic which will be used in Class-map

Create class map to match the traffic,

Create Policy map to mark the traffic

and finally apply the policy map to incoming interface in order to bring policy in effect.

I have created a sample for you consisting of 3 different marking patterns.

STEP 1:- Create ACL's for class-map.


ip access-list extended BULK

remark >> >> SB SWD BIG-FIX <<

permit tcp any eq 52311 any

remark >> Port 80 WWW <<

permit tcp any eq www any

ip access-list extended HIGH

remark >> Citrix Dialog <<

permit tcp any eq 1494 any

remark >> SB Dialog <<

permit tcp any range 4510 4513 any

remark >> SNA Enterprise Extender <<

permit udp any range 12000 12004 any

permit tcp any eq telnet any

permit tcp any any eq telnet

remark >> Fil.Alarm TAS-Link <<

permit tcp any range 53257 53263 any

remark >> -Redbox/AKT- <<

permit tcp any any eq 14804

remark >> ICMP <<

permit icmp any any echo

permit icmp any any echo-reply

ip access-list extended LLQ

remark >> PBX I-LAN <<

permit udp any eq 5004 any eq 5004

remark >> Cisco SLA <<

permit tcp any eq 5004 any eq 5004

remark >> Avistar Video Conferencing <<

permit udp any range 4200 4299 any range 4200 4299

STEP 2:- Creat Class-map to match the traffic


class-map match-all BULK

match access-group name BULK

class-map match-all HIGH

match access-group name HIGH

class-map match-all LLQ

match access-group name LLQ

STEP 3:- Create Policy-map to mark traffic.


policy-map MARK

class LLQ

set dscp ef

class BULK

set dscp default

class HIGH

set dscp cs4

STEP 4:- Apply policy-map on ingress interface.


interface xyz

service-policy input MARK

Hope this helps.........


This Discussion