tftp ios

Unanswered Question
Aug 12th, 2007

hello

i'm using cwlms 2.5

i noticed it is unable to download(tftp) the ios image from a switch. the log file shows it is asking the file from flash: however the file is under a directory in the flash.

is there any workaround?

thanks for any help

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
Joe Clarke Sun, 08/12/2007 - 09:47

This is a known bug which may or may not be fixed in RME 4.1. To know for certain, you will need to provide the exact switch model, and a the swim_debug.log with SoftwareManagement debugging enabled for the job that failed.

ohassairi Sun, 08/12/2007 - 20:25

this is what i obtained in log file

the switch is 3560

C3560-ACC-SW62#

C3560-ACC-SW62#dir /all flash:

Directory of flash:/

2 -rwx 4461 Apr 20 1993 21:18:12 +00:00 config.text

3 -rwx 27 Apr 20 1993 21:18:12 +00:00 private-config.text

4 -rwx 1096 Apr 6 1993 00:20:49 +00:00 vlan.dat

5 drwx 192 Mar 1 1993 00:08:40 +00:00 c3560-ipbase-mz.122-25.SEE2

32514048 bytes total (24354304 bytes free)

C3560-ACC-SW62#

C3560-ACC-SW62#copy flash:c3560-ipbase-mz.122-25.SEE2.bin tftp://10.50.10.150/rep_sw_734661328576358306

Address or name of remote host [10.50.10.150]? 10.50.10.150

Destination filename [rep_sw_734661328576358306]? rep_sw_734661328576358306

%Error opening flash:c3560-ipbase-mz.122-25.SEE2.bin (No such file or directory)

C3560-ACC-SW62#

C3560-ACC-SW62#

C3560-ACC-SW62#disable 1

C3560-ACC-SW62>

C3560-ACC-SW62>

C3560-ACC-SW62>_tune_

C3560-ACC-SW62>

C3560-ACC-SW62>

frankzehrer Sun, 08/12/2007 - 21:21

Hi Oussama,

see the dir of your flash: The "c3560-ipbase-mz.122-25.SEE2" entry is a directory!

You can see this by the first letter after the 5 "d" is inticating a directory!

Therefore no file with the name c3560-ipbase-mz.122-25.SEE2.bin exists.

I guess the switch has an image with a switch manager GUI.?These images are packed as .tar files and decompressed while installing. After installation you will have this directory with a http-server as interface for the GUI.

Best regards,

Frank

Joe Clarke Sun, 08/12/2007 - 22:13

This is a known issue with 3560 images in subdirectories on flash. The problem has been fixed in RME 4.1 (part of LMS 3.0), but is still present in RME 4.0.x. A bug has not yet been filed on this.

Joe Clarke Mon, 08/13/2007 - 21:50

Actually, there have been a few reports that the fix for this was rolled into the latest LibSwim (1.8.1) release for RME 4.0.5 (part of LMS 2.6). So, if you download the LMS 2.6 upgrade, then apply the latest device package, you should be able to archive the IOS found in subdirectories on 3560s.

Actions

This Discussion