Cisco 2621 issues transfering IOS

Unanswered Question
Aug 12th, 2007

Hi,

my first post here. I have a small problem with transfering IOS image to 2621 router.

When I try to tftp the IOS from rommon i get the following error:

TFTP error 0 received (Undefined error code).

TFTP: Operation terminated.

When I try to send the IOS with XModem i get this error:

BB0

ERR:Image size exceeds free flash space

And when i try to dir flash: in rommon i get the following error:

device does not contain a valid magic number

dir: cannot open device "flash:"

I know that the unit itself cannot be faulty, because it worked previously, prior to handing it to me the flash was erased probably.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mihkelpiisang Sun, 08/12/2007 - 09:51

Right now i'm trying to send ios to router with xmodem using switch -r. Should see if that helps anything...but still open to suggestions.

mihkelpiisang Sun, 08/12/2007 - 10:29

Ok my problem is now solved :)

It helped to download ios straight to ram. Then i could easily tftp ios to flash.

Richard Burts Sun, 08/12/2007 - 18:11

Mihkel

I am glad that you got it worked out. And thank you for updating the thread to indicate that you had resolved your issue and how you did this. It makes the forum more useful when people can read about an issue and can read the solution that resolved the issue.

HTH

Rick

Actions

This Discussion