Multicast on FWSM

Unanswered Question

HI,

I am testing my FWSM for Multicast support.

i have made a test set-up..

The Multicast sendor is in "inside"(VLAN 10) & reciever is in "outside"(VLAN 203).

Both the interfaces are not created on MSFC. its only L2 Vlan on 6509E switch.

I tried all my normal application works but multicast is not working though i have configured following on FWSM:

multicast-routing

interface Vlan10

nameif inside

security-level 100

ip address 5.5.5.3 255.255.255.0

igmp join-group 239.255.1.1

pim

interface Vlan203

nameif outside

security-level 0

ip address 6.6.6.1 255.255.255.0

igmp join-group 239.255.1.1

pim

access-list ins_out extended permit ip 5.5.5.0 255.255.255.0 6.6.6.0 255.255.255.0 log debugging

access-list ins_out extended permit ip 5.5.5.0 255.255.255.0 224.0.0.0 240.0.0.0 log debugging

access-list outside_access_in extended permit ip 6.6.6.0 255.255.255.0 5.5.5.0 255.255.255.0 log debugging

access-list outside_access_in extended permit ip 6.6.6.0 255.255.255.0 224.0.0.0 240.0.0.0 log debugging

static (inside,outside) 5.5.5.0 5.5.5.0 netmask 255.255.255.0

access-group ins_out in interface inside

access-group outside_access_in in interface outside

end

Please suggest the problem & workaround.

Thanks in advance!

regards

IMG

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
zubairjalal Mon, 08/13/2007 - 22:52

Hi.

I think the problem lies in the ACL. Please change the ACL so that it points to specific multicast address..

access-list ins_out extended permit ip 5.5.5.0 255.255.255.0 host 239.255.1.1 log debugging

rigoberto.cintr... Tue, 08/14/2007 - 05:06

I don't think the acl is the problem, 224.0.0.0/4 cover the 239.255.1.1.

What I'll try is just make sure that igmp is enable in the necessary interfaces but don't use the join option.

Actions

This Discussion