Catalyst 2960 Series

Unanswered Question
Aug 13th, 2007
User Badges:

I have the above connected to another switch which runs across a 100mb LAN to another switch.


The 100mb LAN switches have been set-up on 100mb full duplex (of so I am told).


I have set up my 2960 with 100mb full duplex and am experiencing the following statistics on the port:


Gi0/3 1090434 5363 30445 29962 0 126 7591 7591


Note the 29962 is FCS errors.


I am no expert, but would hope that someone out there could advise on a fault finding solution etc?


Kind regards,


Mark.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jagdeep Gambhir Mon, 08/13/2007 - 04:53
User Badges:
  • Red, 2250 points or more

Mark,

FCS: FCS error count is the number of frames that were transmitted or received with a bad

checksum (CRC value) in the Ethernet frame. These frames are dropped and not propagated

onto other ports.



Possible cause,

FCS: These are the result of collisions at half-duplex, duplex mismatch, bad hardware

(NIC, cable, or port), or a connected device generating frames with bad FCS.



Have you tried moving this connection to another Port to see if the problem follows the

move?


If you do move the connection and the problem follows the move this indicates the problem

is the switch.


If you move the connection to another Port and all works well then thisindicates an issue

with the Port on that line card.


Please rate helpful posts.


Regards,

~JG

ycae Mon, 08/13/2007 - 05:40
User Badges:

Hi,


clear also the counters to be sure that you are not reading old statistics.


I had an issue with an 2924XL switch and after I did an IOS upgrade to the latest version, everything worked better. May this could also help you.


Yves

markmurrayuk Mon, 08/13/2007 - 05:43
User Badges:

I have cleared the counters, but they are still going up.


Kind regards,


Mark.

markmurrayuk Mon, 08/13/2007 - 05:48
User Badges:

port has faulty link has now started appearing again.


Regards,


Mark.

markmurrayuk Mon, 08/13/2007 - 05:42
User Badges:

Thanks, I have moved the port, but the issue is still there.


I have reset the new port to auto-negotiate and errors are still happening, although I am not getting an error on the link message anymore.


Any further advice?


Kind regards,


Mark.

MUHAMMAD SHAHEEN Mon, 08/13/2007 - 07:27
User Badges:
  • Silver, 250 points or more

Hi,


issue the command #show cdp nei details on your switch.


This should telle you the speed and duplex setup on the remote switch as well as on your switch (the one you have been told).


Then match the speed and duplex settings on your switch. If your speed and duplex are configured then you must match them the same on both ends, but if they are set to auto, then match auto on both sides.


If you still get the errors then change the cable which links both switches.


HTH

Shaheen

stevenmcconnell Wed, 06/27/2012 - 18:21
User Badges:

I had the same issue on my Catalyst 2960 with switch port fa0/24 which was connected to a WRT54G wireless router running DD-WRT v24-sp2 VPN.

I ran the following commands and resolved my issue.

CiscoSW1#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

CiscoSW1(config)#int fa0/24

CiscoSW1(config-if)#duplex full

CiscoSW1(config-if)#speed 100


I tested my cable and that tested good so the issue ended up just being the auto setting on the 2960.

Steve

Actions

This Discussion