Strange config behaviour on 3560 switch

Unanswered Question
Aug 13th, 2007
User Badges:

Hi


I've got some strange conflict occurring on my switch configuration. This is a new switch that's currently being configured, its a 3560 switch.


While setting up the switch I created the following vlan interface:


interface Vlan10

ip address 10.100.1.2 255.255.255.0

ip helper-address 10.1.1.3

standby 1 ip 10.1.3.1

standby 1 priority 120

standby 1 preempt

standby 2 ip 10.100.1.1

standby 2 priority 120

standby 2 preempt


The "2" portion of the hsrp config was copied into vlan 10 by mistake. I removed it by issuing "no" statements before then pressed "Ctrl-Z", I verified the config on vlan 10, so I now have:


interface Vlan10

ip address 10.1.1.2 255.255.255.0

ip helper-address 10.1.1.3

standby 1 ip 10.1.3.1

standby 1 priority 120

standby 1 preempt


I then created a new vlan interface vlan 20 and copied the following lines in:


interface Vlan200

ip address 10.100.1.2 255.255.255.0

ip helper-address 10.1.1.3

standby 2 ip 10.100.1.1

standby 2 priority 120

standby 2 preempt


Now the once I copied those in I get the following errors:

10.100.1.0 overlaps with Vlan10

10.100.1.1 overlaps with Vlan10


Now this is strange, as vlan 10 no longer contains these subnet statements, so my question is why is the switch getting confused, and how can fix the problem?


Thanks in advance

Dan

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Mon, 08/13/2007 - 07:42
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Since you are implementing HSRP, I'm assuming you have another router/switch with a similar config, did you check you eliminated the 10.100.1.1 from that switch's Vlan10 as well ?

Actions

This Discussion