RIPV2 & ACL

Answered Question
Aug 13th, 2007
User Badges:

I am seeing my default route also being distributed even when I have a ACL specifying only one of my static routes? Why is the default route being distributed? Thanks


Here is main part of the config on router 2:

interface Loopback0

ip address 192.168.40.1 255.255.255.0

!

!

interface Serial1/1

no ip address

encapsulation frame-relay

serial restart-delay 0

frame-relay lmi-type ansi

!

interface Serial1/1.101 point-to-point

ip address 192.168.11.2 255.255.255.0

frame-relay interface-dlci 101

router rip

version 2

redistribute static

passive-interface Loopback0

network 192.168.11.0

network 192.168.40.0

distribute-list 14 out static

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 192.168.40.2

ip route 10.1.3.0 255.255.255.0 Loopback0

!

access-list 14 permit 10.1.3.0 0.0.0.255



the routes on Router 1:

Gateway of last resort is 192.168.11.2 to network 0.0.0.0


C 192.168.10.0/24 is directly connected, Loopback0

R 192.168.40.0/24 [120/1] via 192.168.11.2, 00:00:11, Serial1

C 192.168.11.0/24 is directly connected, Serial1/1.101

10.0.0.0/24 is subnetted, 1 subnets

R 10.1.3.0 [120/1] via 192.168.11.2, 00:00:11, Serial1/1.1

C 192.168.1.0/24 is directly connected, FastEthernet0/0

R* 0.0.0.0/0 [120/1] via 192.168.11.2, 00:00:11, Serial1/1.101


R1#sh ip rip da

0.0.0.0/0 auto-summary

0.0.0.0/0

[1] via 192.168.11.2, 00:00:13, Serial1/1.101

10.0.0.0/8 auto-summary

10.1.3.0/24

[1] via 192.168.11.2, 00:00:13, Serial1/1.101

192.168.1.0/24 auto-summary

192.168.1.0/24 directly connected, FastEthernet0/0

192.168.11.0/24 auto-summary

192.168.11.0/24 directly connected, Serial1/1.101

192.168.40.0/24 auto-summary

192.168.40.0/24

[1] via 192.168.11.2, 00:00:13, Serial1/1.101



Correct Answer by Edison Ortiz about 9 years 7 months ago

Change


distribute-list 14 out static


to


distribute-list 14 out Serial1/1.101


Then, clear ip route on R1 and you should have the correct results.

Correct Answer by mohammedmahmoud about 9 years 7 months ago

hi,


Remove the static keyword in the "distribute-list 14 out static" command.


HTH,

Mohammed Mahmoud.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
mohammedmahmoud Mon, 08/13/2007 - 14:35
User Badges:
  • Green, 3000 points or more

hi,


Remove the static keyword in the "distribute-list 14 out static" command.


HTH,

Mohammed Mahmoud.

fgarakani Mon, 08/13/2007 - 15:03
User Badges:

Can you tell me what "static" means/does at the end of "distribute-list 14 out static"? I am really puzzled?


Thanks for your help,


Edison Ortiz Mon, 08/13/2007 - 15:36
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Don't be too puzzled, it doesn't work as advertised. It's a bug (CSCds89505). It does not only affects static but other routing protocols such as OSPF, EIGRP and BGP.

mohammedmahmoud Mon, 08/13/2007 - 15:53
User Badges:
  • Green, 3000 points or more

Hi,


Agree with Edison, practically speaking it never works this way.


HTH,

Mohammed Mahmoud.

Correct Answer
Edison Ortiz Mon, 08/13/2007 - 14:42
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Change


distribute-list 14 out static


to


distribute-list 14 out Serial1/1.101


Then, clear ip route on R1 and you should have the correct results.

Actions

This Discussion